Access'03 Ayuda en registros

Hola, tengo una base de datos con Access 2003. Un formulario principal con datos genéricos de clientes. En este formulario, un botón de comando que me abre otro formulario con datos más concretos filtrando únicamente el registro activo del formulario principal.
En el formulario detallado tengo un subformulario, que es donde se añaden los detalles. Está vinculado a una tabla, donde se guardan los datos.
Mi problema es el siguiente: He ido añadiendo los detalles en el subformulario, de varios clientes... Y después al revisarlo, hay algunos registros, algunos clientes, que no hay manera que se guarden esos datos que añado. Hago exactamente lo mismo para todos los clientes, meto los datos, doy a guardar y salgo al formulario principal. Pero cuando voy a consultar esos datos que metí, no están!
El caso es que abro manualmente la tabla (no el formulario) y los datos están ahí, pero en el formulario se ven algunos registros y otros no. Y el formulario es el mismo para todos.
Ayuda por favor
1

1 respuesta

Respuesta
1
Si no he entendido mal tu consulta los nuevos datos metidos no están porque no se refresca la información en el formulario principal. Voy a suponer que se llama "FPrincipal".
Me dices que tienes un segundo formulario donde metes los datos con más detalle. Entonces...
.- Abres ese formulario "secundario" (para entendernos) en vista diseño.
.- Sacas las propiedades del formulario, te vas a la pestaña Eventos, y te vas al evento "Al cerrar". Te pones en la parte blanca que hay a la derecha y te aparecerá un pequeño botón con puntos suspensivos. Haces click sobre él y en la ventana que te sale le dices que quieres generar código.
.- Se te abrirá el editor de VB. Entre las dos líneas por defecto que te salen escribes simplemente:
---
Private Sub...
Forms![FPrincipal].Refresh
End Sub
---
Tienes que cambiar FPrincipal por el nombre de tu formulario principal.
Ya me dirás si te ha funcionado.
Muchas gracias por la rapidez, aún no me sale. :( Te cuento con los nombres reales que tengo, aunque creo que me entendiste bien, pero no me salió.
El formulario principal se llama [1_Propietario_solicitante], en él hay datos personales básicamente, está vinculado a la tabla [1_Propietario_solicitante]
Tiene un botón de comando que se llama "parcelas", le pico y abre un formulario llamado [Parcelas socios], que filtra el registro activo, muestra el nombre del cliente que está visible en el formulario principal.
Dentro de [Parcelas socios], hay un subformulario llamado [Subformulario Parcelas_socios] que está vinculado a la tabla [Parcelas_socios].
Pues bien, hice lo que me dijiste y nada, sigue igual. Voy a la tabla Parcelas_socios, y hay datos, pero entro en el formulario y no aparece nada, está en blanco.
Pues así, "a distancia", no se me ocurre qué puede estar pasando. Tendría que ver tu BD para ver cómo tienes estructurada la BD. Si quieres pásame una copia comprimida en zip a mi mail. Si tienes registros "confidenciales" puedes borrarlos tranquilamente, aunque te ruego me dejes algunos para poder hacer pruebas, aunque sean inventados.
Mi correo es [email protected]
No te podré contestar con tanta rapidez como hasta ahora, pero tranqui que en cuanto pueda le echo un vistazo y te digo cosas.
Ya me dirás.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas