Agustin Lopez

Agustin Lopez

 Paraguay @lordtrebol desde - visto
Preguntar

Actividad pública reciente

Ha preguntado en el tema en

Cómo ingresar función Si anidadas cuando quiero comparar valores

Mi gran experto Dante tengo una duda respecto a la función si tengo una planilla donde figura su ruc con su dv separado por un guión lo que quiero hacer es separar el numero del dígito verificador y los que no tienen calcular su dv usando una fórmula...
Ha valorado "Excelente" la respuesta

Pasar los datos del formulario a la hoja usando userform excel

respondió: H o l a: Te anexo el código para pasar los datos a la hoja Set h3 = Sheets("" & cod) 'Poner datos: h1.[B3] = cod h1.[D3] = art h1.[B5] = fecini h1.[D5] = fecfin ' fila = 9 h1.Cells(fila, "A") = h3.Cells(14, "L") u3 = h3.Range("B" &...
Ha valorado "Excelente" la respuesta

Como buscar artículos de un inventario en excel usando vba

respondió: Te anexo la macro para consultar un artículo o todos los artículos Private Sub CommandButton1_Click() 'Por.Dante Amor Set h1 = Sheets("RESUMEN") Set h2 = Sheets("INVENT") ' 'limpiar hoja h1.Range("A9:G" & Rows.Count).ClearContents If CheckBox1 =...
Ha valorado "Excelente" la respuesta

Como invocar movimientos de todos los artículos de una planilla inventario hecho en excel vba con rango de fechas

respondió: Envíame un correo nuevo con el archivo y en la hoja Resumen, me pones un ejemplo de cómo quieres ver la consulta de todos los artículos. R ecuerda poner tu nombre en el asunto.
Voto positivo a la respuesta

¿Cómo limpiar campos de distinto tipo con arreglo en VBA Excel?

respondió: H o l a: Para ilustrar mi ejemplo, voy a suponer que el formulario UserForm2 tiene los textbox, combobox y checkbox que se van a limpiar. Para limpiar todos los textbox, combos y checks de un formulario, pon lo siguiente en un módulo: Sub...
Ha valorado "Excelente" la respuesta

Como trasladar calculos de stock usando un listbox en excel vba

respondió: Te anexo el código para los cálculos h1.Cells(fila, "E").FormulaR1C1 = "=RC[-4]+RC[-3]-RC[-2]-RC[-1]" h1.Cells(fila, "G").FormulaR1C1 = "=RC[-1]*RC[-2]" La macro: Private Sub CommandButton1_Click() 'Por.Dante Amor Set h1 = Sheets("RESUMEN") Set h2 =...
Ha valorado "Excelente" la respuesta

Como crear listbox en excel vba para reportar con rangos de fechas o periodo a elegir

respondió: H o la: Reviso el correo y te aviso si tengo dudas.
Ha valorado "Excelente" la respuesta

Usar Combobox como criterio de búsqueda en excel vba

respondió: Te anexo el código para un listbox Dim h1 ' Private Sub ListBox1_DblClick(ByVal Cancel As MSForms.ReturnBoolean) 'Por.Dante Amor hoja = ListBox1.List(ListBox1.ListIndex) existe = False For Each h In Sheets If LCase(hoja) = LCase(h.Name) Then existe =...
Ha valorado "Excelente" la respuesta

Extracción de RUC & DV en excel con fórmulas

respondió: Para calcular el RUC utiliza esta fórmula: =SI.ERROR(IZQUIERDA($A3;ENCONTRAR("-";$A3)-1);$A3) Para calcular el dígito verificador, con la siguiente macro: Sub CalcularDv() 'Por.Dante Amor Set h1 = Sheets("Hoja1") Set h2 = Sheets("Hoja2") For i = 3 To...