Vincular un libro con otros dos...

Hola grupo, mi inquietud es: Tengo un libro principal en donde aparecen todos mis empleados.
Tengo dos libros secundarios, en donde aparecen ciertos descuentos, no a todos los empleados. Necesariamente estas hojas están en libros diferentes.
Ejemplo:
Libro 1:
Codigo Nombre Bruto desc 1 desc 2 Neto
1. Pepe 100.00 0.00 5.00 95.00
2. Juan 200.00 20.00 0.00 180.00
3. Pedro 150.00 10.00 15.00 125.00
Libro 2 Desc 1
2. Juan 20.00
3. Pedro 10.00
Aquí no aparece Pepe
Libro 3 Desc 2
1. Pepe 5.00
3. Pedro 15.00
Aquí no aparece Juan
¿Cómo puedo vincular el libro 1 con los otros dos, de forma que aparezcan los descuentos a c/empleado? Lo intente con buscarv, pero en el libro 1 al buscar a Pepe en el libro 2 (a través de su código), y al no encontrarlo, me pone el descuento de Juan (me imagino porque es el más próximo), y de igual forma con el libro 3... Gracias anticipadas

1 respuesta

1
Respuesta de
Mira, lo primero que debes hacer es ordenar libro2 y libro3 por el código (supongo que es la columna A, columna B será el nombre y C el descuento)
Luego en el libro1, que supongo en la columna DE irá el descuento1 y en la E el desc 2 (igual en la columna A estará el código).
en la celda D2 (desc1 de Pepe) escribe la fórmula =SI(ESERROR(BUSCARV(A2,Libro2.xls!$A$2:$C$7,3,0)),0,BUSCARV(A2,Libro2.xls!$A$2:$C$7,3)) y copiala para abajo, y en E2 =SI(ESERROR(BUSCARV(A2,Libro3.xls!$A$2:$C$7,3,0)),0,BUSCARV(A2,Libro3.xls!$A$2:$C$7,3)) y también copia hacia abajo.
Creo que con eso tienes resuelto tu problema
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje