Copiar fila a otra hoja si = valor en columna

Respuesta de
a
Usuario
Hola y gracias anticipadas por su tiempo.
En excel 2003 en una hoja A tenemos:
Numero Dato1 Dato2 ......
1
3
7
25
...
Quisiera que se copiara a otra hoja B, que tiene en la primera columna los valores Numero del 1 al 45000, solo aquellas filas que tengan el
mismo dato, es decir, copiar la fila que contenga 25 en la hoja A en la fila que contenga 25 en la hoja B
Avatar
Experto
Hola

Suponiendo que los valores de A no se repiten puedes usar un consulta b, que en office 2003 seria buscarv.

La fórmula seria

=BUSCARV(A2;Hoja1!A:A;1;FALSO) Esta formula va al lado del valor de la columna B, suponiendo que es la celda A2.

Luego arrastras la fórmula para reproducirlas en las demás celdas.

Espero haberte ayudado
Usuario
Muchas gracias por tu respuesta, funciona para encontrar si un valor determinado de una columna en una hoja esta en otra columna de otra hoja. Pero lo que quiero es se copie la fila

Hoja A numero dato1 dato2 dato3

1 25 46 75

3 34 72 23

7 1 4 5

------

Hoja B numero

1

2

3

-----

Quiero que en la fila 1 copie los datos 25, 46, 75, ---. La 2 la deje en blanco y en la 3 copie los datos 34, 72, 23 y así sucesivamente.

Gracias anticipadas por vuestra ayuda. Un cordial saludo.
Avatar
Experto
Ok

Aquí subo un ejemplo, el archivo se llama ejemplo a ver si hace lo que necesitas

http://cid-e5f28d555f68f3cc.office.live.com/browse.aspx/P%c3%bablico



Saludos
Usuario
Muchas gracias, excelente solución que funciono perfectamente con las adaptaciones para Excel 2003.