Cálculos de tiempos en excel

Hola Villaju, placer virtual de conocerte.
Tengo un problema que espero me resuelvas, es acerca de cálculos de tiempos: te envío una "hojita", donde verás he calculado las horas y los minutos de diferencia entre dos horarios dados, también calculé sin problemas con las funciones RESIDUO y SUMA los minutos, pero al tratar de sumar las horas, lo más aproximado es una hora de diferencia ¿por qué?
A B C D E
Fecha Entrada Salida Horas Minutos
01-jun 10:10 16:30 6 20
02-jun 10:20 15:50 5 30
03-jun 10:25 15:00 4 35
04-jun 8:00 16:00 8 0
05-jun 9:00 14:59 5 59
06-jun 7:00 15:59 8 59
07-jun 8:40 14:00 5 20
08-jun 9:00 11:00 2 0
09-jun 7:00 14:57 7 57
Desde el periodo entre el 01-jun hasta el 09-jun
se han registrado 55 horas 40 minutos
función utilizada para averiguar las horas:
=SUMA(E5:E13)/60+SUMA(D5:D13)
función para averiguar los minutos:
=RESIDUO(SUMA(E5:E13);60)

1 respuesta

0
Respuesta de
Hola! ¿Cómo va todo? No he entendido bien lo de "lo más aproximado es una hora de diferencia". Bien, espero acertar en la respuesta y que mis consejos te sean útiles: en principio, cuando tú sumas dos horas en Excel, si el resultado traspasa las 24 horas, Excel entiende que es un día y tantas horas. Me explico: si sumas 23:10 y 2:05, el resultado es 1:15 (en vez de 25:15). Para solucionar este problema se usa un formato personalizado. En tu caso, si quieres saber las horas de diferencia entre una hora inicial y otra final, bastaría con poner: C5-B5, y luego ir a Formato-Celdas-Número, allí escoger la categoría "Personalizada" y escribir [h]. Con esto te saldrán las horas, y a la hora de sumarlas no tendrías que tener mayor problema. También te informo de que existen las funciones =HORA y =MINUTO, capaces de sacar la hora y los minutos de una fecha dada. En fin, insisto en que no sé si habré acertado bien en lo que querías, si fuese así, por favor, ten en cuenta el esfuerzo realizado y finaliza la pregunta. Si quedó algo sin aclarar, vuelve a preguntarme y con gusto te ayudo. Un saludo.
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje