¿Php4.0.4=php4.0.4pl1?

Hola Juan Ignacio, muy buena la guía de instalación de apache como servidor seguro. Lo que yo estoy haciendo es solo un portal, tal vez no necesito tanto como openssl y apachessl, pero de todas formas los instale. Instale ademas (en linux) el php4.0.4pl1, pero tu decías que era necesario el php4.0.4 no se si es el mismo, y si no, no se que enconveniente pueda tener, También encontré que para probar la instalación se crea un fichero llamado test.php3 con la siguiente linea:
<?php phpinfo() ?>
Colocarlo en el directorio de documentos de Apache y llamarlo desde el navegador, bueno hice el fichero y lo gurde en el directorio
/scr/apache/htdocs, tambien probe con extension phtml y php4.
Abrí el navegador y coloque la dirección file:/src/apache/htdocs/test.php3
y pensé que me entregaría una pag de información, pero me entrego una pag con la linea <?php phpinfo(¿)?> . No se si lo coloque en un directorio equivocado o lo llame mal desde el navegador.
Con respecto a las lineas:
AddType application/x-httpd-php .php
AddType application/x-httpd-php .php3
AddType application/x-httpd-php .php4
AddType application/x-httpd-php .phmtl
AddType application/x-httpd-php-source .phps
las ubique todos los archivos httpd.conf que encontré.
¿Qué puedo estar haciendo mal?
1

1 respuesta

Respuesta
1
Php4.0.4pl1 es la siguiente versión tras php4.0.4. Creo que corrige algunos pequeños problemas que presenta php4.0.4. Por lo tanto, no hay diferencias entre instalar uno u otro, salvo que tengas cuidado de colocar bien los nombres, puesto que las instrucciones de mi página están pensadas para instalar php4.0.4.
Por lo que me dices, apache no te está interpretando las páginas php com tales, sino como simples documentos html. La configuración AddType aparentemente la tienes bien por lo que me dices, de forma que lo que puede estar ocurriendo es que el apache que has compilado no lleve integrado php4. Una forma sencilla de comprobarlo es navegar por la siguiente url:
http://www.tudominio.com/server-info
Tiene que poner algo así como:
Server Version: Apache/1.3.12 Ben-SSL/1.40 (Unix) PHP/4.0.4pl1
Si no pone lo de PHP/4.0.4pl1 significa que no tienes incluido el soporte PHP4 en Apache, por lo que tendrás que volver a compilar Apache y luego instalarlo.
Sigue estos pasos:
### Compilo PHP4 como modulo de Apache
cd /usr/src/php
./configure --with-mysql=/usr/local/mysql --with-apache=/usr/src/apache --enable-track-vars
make
make install
cp /usr/src/php/php.ini-dist /usr/local/lib/php.ini
### Compilo Apache
cd /usr/src/apache
./configure --prefix=/usr/local/apache/ \
--activate-module=src/modules/php4/libphp4.a \
--activate-module=src/modules/standard/mod_speling.o \
--activate-module=src/modules/standard/mod_info.o
make
### Paras apache
/etc/rc.d/init.d/httpsd stop
make install
### Inicias apache
/etc/rc.d/init.d/httpsd start
¿Te funciona ahora?
Si es así, te agradeceré me des una buena puntuación. Si no, dame más información sobre el error que recibes y quizá te pueda ayudar. Gracias.
Esta información la tienes en http://jips.kipelhouse.com/linux/apache/ssl/
Php4.0.4pl1 es la siguiente versión tras php4.0.4. Creo que corrige algunos pequeños problemas que presenta php4.0.4. Por lo tanto, no hay diferencias entre instalar uno u otro, salvo que tengas cuidado de colocar bien los nombres, puesto que las instrucciones de mi página están pensadas para instalar php4.0.4.
La URL file:/src/apache/htdocs/test.php3 carga la página web directamente del disco duro, sin que apache la procese. Para que PHP funcione, debes solicitar la página como si estuviera colocada en Internet, o sea http://www.midominio.com/test.php3
Si aún así no funciona, es porque apache no te está interpretando las páginas php com tales, sino como simples documentos html. La configuración AddType aparentemente la tienes bien por lo que me dices, de forma que lo que puede estar ocurriendo es que el apache que has compilado no lleve integrado php4. Una forma sencilla de comprobarlo es navegar por la siguiente url:
http://www.tudominio.com/server-info
Tiene que poner algo así como:
Server Version: Apache/1.3.12 Ben-SSL/1.40 (Unix) PHP/4.0.4pl1
Si no pone lo de PHP/4.0.4pl1 significa que no tienes incluido el soporte PHP4 en Apache, por lo que tendrás que volver a compilar Apache y luego instalarlo.
Sigue estos pasos:
### Compilo PHP4 como modulo de Apache
cd /usr/src/php
./configure --with-mysql=/usr/local/mysql --with-apache=/usr/src/apache --enable-track-vars
make
make install
cp /usr/src/php/php.ini-dist /usr/local/lib/php.ini
### Compilo Apache
cd /usr/src/apache
./configure --prefix=/usr/local/apache/ \
--activate-module=src/modules/php4/libphp4.a \
--activate-module=src/modules/standard/mod_speling.o \
--activate-module=src/modules/standard/mod_info.o
make
### Paras apache
/etc/rc.d/init.d/httpsd stop
make install
### Inicias apache
/etc/rc.d/init.d/httpsd start
¿Te funciona ahora?
Si es así, te agradeceré me des una buena puntuación. Si no, dame más información sobre el error que recibes y quizá te pueda ayudar. Gracias.
Esta información la tienes en http://jips.kipelhouse.com/linux/apache/ssl/

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas