ASP y ADO con Oracle

Hola...
Tengo un problema bastante raro con ADO y ORACLE...
Pasa que trabajo en una aplicación con ASP y componentes VB (6) y estoy conectado a una BD Oracle 8.05 (creo). Además, el servidor es Microsoft IIS.
Tengo una serie de Procedimientos Almacenados en mi Oracle, pero uno de ellos no me quiere funcionar porque posee 16 parámetros, siendo que 15 si me los acepta.
También lo probé con PWS como web server en vez de IIS pero ahí funciona re-bien, sin embargo lo requierio con IIS por política.
No se qué le pasa con el ADO y el Provider (porque eso uso) con IIS... ¿Habrá una configuración especial en VB? ¿En el IIS? ¿En el PC?
Gracias.
3

3 Respuestas

15.600 pts.
¿Me puedes dar el error que obtienes?
de todas formas por si te es de ayuda, hay unos cuantos problemas reconocidos
entre iis y oracle. En la dirección : http://support.microsoft.com/support/kb/articles/Q255/0/84.asp
Tienes una referencia.
Si tienes alguna duda sobre la url que te indico dímelo
Solo se que no funciona... es decir, se cae la VB... :-(...
Sorry... pero veré que hay en la página... gracias... :-)
Si quieres más ayuda, pásame parte del código, para poder ver algo más :-)
Acuérdate de todas formas de finalizar la pregunta plis ;-) (siempre que no necesites más info :-))
Ok...
No puedo pasarte el código porque lo hago a través de componentes de componentes y me sería medio complicado poh... :-)
Pero gracias igual...
4.525 pts.
No estoy muy familiarizado con el IIS ya que casi no lo utilizo, pero lo que si se es efectivamente tienes que configurarlo antes de usarlo, fíjate en el panel de control y busca un icono perteneciente al IIS. Ábrelo y ahora busca los parámetros que necesites, es muy importante que recuerdes la versión de Oracle que manejas porque a lo mejor necesitas configurarla en el IIS. Dejema ver que más puede averiguar y te lo paso al costo, nos vemos.
29.725 pts.
La verdad, que no he trabajado nunca con IIS, ni con Oracle, aunque si tengo experiencia en MTS, VB, ADO y SQL Server. Por lo que me dices el problema está en IIS y su comunicación con Oracle.
Yo he montado aplicaciones en 3 capas con MTS, VB, ADO y SQL Server y no he tenido ningún problema. He hecho procedimientos almacenados que superan con creces los 16 parámetros y todo ha ido bien. Casi me atrevería a descartar la configuración de IIS ya que éste lo que hace es utilizar MTS (y supongo que algo más pero te repito que no lo he utilizado).
Espero que te sirva de guía, y te permita descartar algunas de las posibles causas.
Un saludo
Salvador Ramos
www.helpdna.net

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas