Contar las veces que aparecen números en una matriz

En la matriz

3 9 7 4 11

4 12 3 1 32

11 15 17 3 4

Una macro que me calcule cuantos 3 y cuantos 4 hay en todo el rango.

Agradecido por sus respuestas

2

2 Respuestas

50.130 pts. A pregunta detallada, respuesta exacta. A pregunta...

Supongo que la matriz es de 3 filas y 5 columnas, tal y como la pintas.

En ese caso, yo las he colocado en el rango A1:E5, como se ve:

Y ésta es la fórmula que debes usar:

=CONTAR.SI(A1:E3;3)+CONTAR.SI(A1:E3;4)

Confirma si te vale.

Perdón. El rango de celdas donde las he colocado es A1: E3

158.725 pts. Si de mis mayores gustos, mis disgustos han nacido,...

Esta es otra manera con formula

+CONTAR. SI. CONJUNTO(B4:F6,">2", B4:F6,"<5")

y esta es con macro

Sub contar_34()
Set datos = Range("b4").CurrentRegion
With datos
    cuenta = WorksheetFunction.CountIfs(datos, ">2", datos, "<5")
End With
Set datos = Nothing
End Sub

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas