Obtener valor e inventario a partir de los datos descendentes en Microsoft Excel

Realmente me causa un dolor de cabeza! No puedo trabaja en forma descendente !, necesito buscar un valor próximo a 670 y al obtener este valor próximo obtenga el inventario
Densidad inventario
671.71 100225.02 valor buscado 670
670.24 100231.35 valor encontrado 670.24
669.69 100290.85 valor del inventario 100231.35
667.21 100302.02
660.89 100324.75
Gracias
1

1 respuesta

Respuesta
1
Interesante problema
En que columna están las densidades (columna y fila), ¿en qué columna el inventario?
¿En dónde deseas el resultado? (¿Celda?).
A ver que se puede hacer.
A B c
1 densidad inventario
2 671.71 100225.02 valor buscado= 670
3 670.24 100231.35 valor encontrado= 670.24
4 669.69 100290.85 valor DEVUELTO (del inventario)= 100231.35
5 667.21 100302.02
6 660.89 100324.75
Ok.
Para eso lo que haremos es lo siguiente:
Digita la densidad a buscar en celda D1
Debes insertar una columna entre "densidad" e inventario en esta columna debes poner esto:
=SI(($D$1-A2)<0;($D$1-A2)*-1;($D$1-A2))
Entendiendo que la data parte desde la fila 2 ( supongo que fila 1 están los rótulos)
Bueno lo anterior es sencillamente determinar el diferencial que existe entre la densidad a buscr y las densidades existentes todas obviamente en valores mayores a cero, es cierto que dan menores a cero también, pero para efectos de que la busquead sea exitosa los expresaremos en positivos.
En celda E1 pon esto:
=BUSCARV(MIN(B2:B6);B2:C6;2;FALSO)
Esto buscara el valor mínimo de la columna diferencial y te devolverá el dato de inventario que tenga a su derecha. no es mas que eso
Ya ves, lo que había que determinar era cual de los diferenciales esta más cerca del cero
bye

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas