¿Qué puedo hacer para que se carguen películas flash en php?

Como hago para que se carguen películas flash en php, tengo apache bajo windows xp, el php corre bien pero las películas que le coloco al documento php no las carga el explorador, y no es falla del internet explorer porque al usar el el documento como .html y no como .php fuera del apache si se cargan las películas.
5

5 Respuestas

591.125 pts. Licenciado en Informática
No tiene nada que ver que la página sea PHP o HTML para que se vea un Flash.
Carga los HTML en el Apache y verás como también te funciona.
Controla la seguridad del Apache a ver si es que no le estás dejando ejecutar archivos SWF de Flash.
Espero haberte orientado!, no olvides cerrar la pregunta!.
Ok, bueno en el caso de la seguridad, ¿en qué lado puedo verificar la seguridad del apache?
Saludos
Puedes mirar en el archivo httpd.conf, aunque el problema está extendido, puedes mirar en este foro:
http://www.planetalinux.com.ar/forum/ptopic1937.html&sid=ca221d0a7389f75be490b95cab775306
4.450 pts. Cursando 5to año de Ingenieria en Sistemas de...
Antes que nada me gustaría saber de qué manera estas cargando el documento flash en la página, es decir, si las películas las estas cargando con funciones específicas de php como las funciones Ming o directamente estas embebiendo html dentro de php. Te pregunto porque en el caso de que directamente estés embebiendo html en la página php, ese código es interpretado directamente por el internet explorer y el servidor Web ni lo mira. En cambio si estas usando librerías específicas de php para cargar las películas flash es otro tema que tendría que verlo más en detalle porque estas librerías no son muy usadas en windows.
Entonces necesitaría que me digas eso o bien que me muestres de que manera estas tratando de cargar las películas php ya que en principio el hecho de que cargues flash, java, o cualquier tipo de código desde html debe ser exactamente lo mismo para las páginas php.
Ok, yo para cargar el archivo swf estoy utilizando html, con la etiqueta <embed>, ahora lo extraño es que si la página tiene extensión .html el me carga el flash sin problema (claro esto lo hago fuera del apache), ahora cuando le cambio la extensión a .php y lo coloco bajo el apache (en el directorio de publicación), no me carga la animación flash (claro, si me interpreta bien la instrucciones php).
Yo creo que es algo de seguridad del apache... ¿alguna idea?
Saludos
Ok. Por lo que me comentas te faltaría probar la página con la extensión .html en el servidor, bajo apache, de la misma forma que probas php y ver si funciona. De esta forma descartas un problema de apache.
No se si ya lo habías probado pero el tema es que el servidor no se encarga de interpretar flash, lo único que hace es devolver todo lo que sea html al browser para que este lo interprete. Por eso me parece extraño que no te funcione bajo apache. Asegurate de que el archivo html se encuentre en el mismo directorio que el archivo .php, te lo digo porque me decís que la página html la probas fuera del apache siendo esto, en tal caso, un problema de rutas.
Otra cosa que te recomiendo es que te bajes algún archivo que sepas que esta funcionando en internet, algo que hayas hecho antes puede ser. Lo que sea que te asegure que funciona. Proba servir ese archivo con su objeto flash bajo apache y fíjate que sucede. Si te funciona, entonces hay un problema con el código de tu archivo.
Proba levantar otro archivo flash desde la misma página php. Fíjate bien las rutas.
Proba cambiar el nombre del objeto flash y fíjate si te da el mismo error.
Bueno son algunas cosas que se me ocurren en este momento. Si no te funciona nada de lo que te sugerí comentame cuales fueron los resultados de cada prueba para poderte sugerir algunas otras cosas.
41.425 pts.
Cuando la página php es interpretada por el navegador ya está traducida a html, de modo que el que se trate de una página no html no debe suponer ningún problema. Cuando se haya cargado la página haz clic en botón derecha/ver código para comprobar si la llamada al flash está bien escrita.
Otra posible causa es que la ubicación del archivo swf no sea la correcta respecto a la ruta del script (servidor local).
Si no lo solucionas envía el código, igual hay algún error tipográfico o de programación php.
Saludos,
iNphYx
Dentro del archivo de configuración del Apache httpd.conf tiene que estar definido el tipo de aplicación asociada a los swf. Añade la línea
AddType application/x-shockwave-flash .swf .cab
dentro de la directiva <IfModule mod_mime.c>
5.550 pts.
Disculpa por la demora pero creo que la solución debe ser la siguiente.
<?
echo"<object>";
echo"<param name="movie" value="nombre_pelicula.swf">";
echo"<param name="quality" value="high">";
echo"<embed src="nombre_pelicula.swf" quality="high" type="application/x-shockwave-flash" width=550 height=100></embed></object>";
?>
8.225 pts. Actualmente soy consultor en tecnologias Oracle en los...
Como recomendanción inserta el código htm que manda a llamar al flash dentro de tu código de php con esto no deberías tener problemas

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas