Problema en informe Gráfico

Hola a todos, espero que puedan ayudarme en este problema que no encuentro motivo o falla aparente.
Tengo una pequeña base en Access 2000, para consulta de datos o algún gráfico entre una determinada fecha. En un formulario selecciono de un combo el dato (DatoX) y las fechas me las da por Default, al oprimir botón para ver el informe gráfico y me lo da o.k., el problema viene cuando le doy cerrar y me vuelve al formulario y al cambiar el dato (DatoY) y al graficar nuevamente a veces, NO SIEMPRE me da el gráfico que consulte anteriormente (DatoX), como si se quedara en memoria el dato anterior y por consiguiente me gráfica datos que no quiero aunque en el COMBO haya otro valor (?)
Valores en consulta:
[Forms]![ParaInformes]![Combo56] Es el valor en el criterio de la consulta.
Y para la fecha:
Between [Forms]![ParaInformes]![FechaInicial] And [FechaFinal]![ParaInformes]![Text14]
Gracias de antemano
Mreyes
1

1 Respuesta

14.300 pts. AS/400 Amplia experiencia por mas de 15 años en...
Entonces todos los objetos de tu formulario ponlos en nothing ..y las variables en NULL
Si te refieres al "control source", así es como está, o sinceramente no entiendo tu respuesta, ja... perdón por mi poco conocimiento, te agradecería me ampliaras tu respuesta, gracias.
Mario, saludos
Perdón por el retraso, mira que ya hice lo del refresh, y creo que ya sé cuál es el error, pero lo que no sé es como resolverlo.
Resulta que cuando estoy en modo diseño del informe, el gráfico me queda con datos "basura", entonces a veces cuando veo el informe modo vista preliminar, me muestra datos de lo que hay en modo diseño, lo que hice para "resolver" el problema según yo, fue que en modo diseño entré al gráfico y le borré los datos en la tabla (en modo diseño del informe), entonce lo que pasa es que a veces me muestra un gráfico sin datos, esto pasa aunque el resultado de mi informe venga de una consulta.
Es preferible que me muestre "nada" a que me muestra datos de otra cosa que no quiero y provoque la confusión.
Gracias, espero me haya dado a entender.
Mario
Por que no hace un me. Refresh del formulario.. de seguro el problema desaparecerá...
Se agradece la respuesta y tiempo, pero no me sirvió, el problema continúa.
Yo creo que basta con reinicializar el control con los valores que tenia antes de ingresar algún dato...

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas