Función =SI usando fechas.

Buenas noches ante todo. Tengo un ejercicio que resolver que por cierto nunca enseñó el profe, el cual es el siguiente.:
Tengo una lista de la siguiente. Manera:
Fecha de ingreso - Mostrará
Antes 1980 (>=31/12/1979) 150
*Entre 1980 y 1990 (1/1/1980 al 31/12/1990)                         100
*Después de 1990 y antes 2001   (1/1/1991 al 31/12/2000)   80
Después del 2000  (>=1/1/2001)                                              50
Requiero determinar un bono de acuerdo a la fecha de ingreso, para esto uso la función si, y la fórmula que empleo es la sgte.: =SI(H10<=FECHA(1979,12,31),150,SI(H10>=FECHA(1980,1,1)<=FECHA(1990,12,31),100,SI(H10>=FECHA(1991,1,1)<=FECHA(2000,12,31),80,SI(H10>=FECHA(2000,1,1),50,0))))
Para el primer y último caso responde, el problema es cuando comparo entre 2 fechas(las del asterisco *), no sé si está bien escrito o le falta algún argumento, carácter, paréntesis o algo a la fórmula.
Desde ya muchas gracias.
1

1 respuesta

1
Respuesta de
El problema que tienes es que estás "juntando" mal los casos de dos condiciones.
Por ejemplo para
Entre 1980 y 1990 (1/1/1980 al 31/12/1990) 
Lo que necesitas es que la fecha sea Mayor o Igual a 1/1/1980 Y Menor o Igual a 31/12/1990. Lo que te está faltando es el Y.
La forma de unir dos condiciones lo debes de hacer con los operadores lógicos Y o O, en este caso Y.
Entonces tu condición será
 Y(H10 >= Fecha Inicio , H10 <= Fecha Final)
El resto te lo dejo para que lo completes de manera que no diga tu profe que te hicieron toda la tarea.
Si he logrado ayudarte te agradezco que cierres la pregunta, de lo contrario me avisas.
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje

Más respuestas relacionadas

¿No es la pregunta que estabas buscando?
Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: