Problemas con TS en W2KS

Tengo un servidor de W2KS al que acceden 3 usuarios TS vía RDSI para ejecutar un programa que tengo en clipper 5.2 de 16Bits.
Aunque el Servidor tiene 256 Mbs de Ram, 2 Pentium III 600 Mhz con disco duro Ultra SCSI de 160 Mb/Seg se me muere, veo en las tareas que ejecutan un proceso NTVDM.EXE que se come el 50 % de recursos y me mata el Servidor ¿cómo puedo resorber esto? ¿Puedo Compilar el programa a 32Bits?
Muchas Gracias
2

2 respuestas

Respuesta
Por lo que escribes creo que tu problema esta en el programa. No te va a ayudar compilarlo en 32bits.
El programa por lo visto no sabe liberar recursos. Para solucionar el problema conviene leer la explicación de como programar para TS en el site de microsoft.
Yo tengo varios servers no muy superiores a el tuyo en los cuales trabajan cerca de 25 ususrios a la vez sin problemas de ese tipo.
Respuesta
El problema no es de maquina o de conexión, es simplemente que a NT le sientan fatal las aplicaciones de 16 bits; para cada instancia tiene que crearte una "maquina virtual" (NTVDM=NT Virtual Dos Machine) e ir trasladando el entorno de modo real propio del DOS al modo protegido propio de windows y eso penaliza, especialmente si la aplicación DOS hace polling constantemente de algún recurso como el teclado o el puerto serie.
Dale un vistazo a la KB de Microsoft (Q165214) y prueba a lanzar la aplicación directamente desde el interprete de comandos como:
CMD.EXE /C <aplicacion> /Q
Wopr.
No se si no te he entendido bien,
Te explico, me he ido al connection manager de ts y he cambiado el programa por cmd.exe /c M:\ges\apli.bat /Q y sigue igual.
Como veo el KB
Gracias por tu interés

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas