Dante Amor

Dante Amor

Excelente!
 3.288K puntos  Estado de México, México @aprendemos desde - visto
Preguntar

Preguntas y respuestas en Microsoft Excel

Como ver coincidencias de una columna y otra y pasar el resultado de la tercera

Pon la siguiente fórmula en la celda B2 =SI.ERROR(BUSCARV(A2;E:F;2;0); "No existe") Arrastra o copia la fórmula hacia abajo hasta el final de las facturas de la columna A. ' 'S aludos. Dante Amor. Recuerda valorar la respuesta. G racias
Respuesta en y en 1 temas más a

Buscar una cadena dentro una celda en excel y devolver un valor

Pon la siguiente fórmula en la celda B1 =SI.ERROR(SI(ENCONTRAR("x t -60 %",A1)>0,"SI", ""), "") copia o arrastra la fórmula hacia abajo. 'S aludos. Dante Amor. Recuerda valorar la respuesta. G racias
Respuesta en y en 2 temas más a

Macro para eliminar ciertas columnas de una tabla filtrada:

H o la: Según tus comentarios, primer realizar un filtro por fecha, entonces, en la siguiente macro cambia la letra "D" por la columna donde tienes esas fechas. También cambia el 1 por el número de fila donde tienes los encabezados En estas líneas...
Respuesta en y en 3 temas más a

VBA: no puedo seleccionar una celda

No puedes seleccionar una celda si estás en otra hoja, primero te tienes que seleccionar la hoja y después seleccionar la celda: i = 1 Sheets(i).Select ActiveWorkbook.Sheets(i).Range("A3").Select o puede ser: i = 1 Sheets(i).Select Range("A3").Select...
Respuesta en y en 2 temas más a

Error en listbox1 por problema de filtracion

No puedes utilizar additem y rowsource al mismo tiempo. En este caso como vas a filtrar y a cargar con additem. Entonces hay que cargar con additem desde el inicio: Private Sub UserForm_Initialize() Application.DisplayAlerts = False Set b =...
Respuesta en y en 3 temas más a

Reparar codigo de para crear base de datos

Quedaría así: Private Sub CommandButton4_Click() Set a = Sheets("history") fila a.range("A" & rows.count).end(xlup).row + 1 For i = 0 To ListBox1.ListCount - 1 a.Cells(fila, 4).Value = ListBox1.List(i, 0) 'PRODUCTO a.Cells(fila, 5).Value =...
Respuesta en y en 1 temas más a

Obtener número de fila de item selccionado de listbox

Envíame tu archivo con el userform para revisarlo, explícame con un ejemplo lo que necesitas. R ecuerda poner tu nombre de usuario en el asunto.
Respuesta en y en 2 temas más a

Deseleccion y parpadeo de un Cuadro de Control ListBox

H o la Una opción es que borres la celda H2. La otra opción es que pongas el siguiente código en los evento de la hoja donde tienes el listbox Private Sub ListBox1_DblClick(ByVal Cancel As MSForms.ReturnBoolean) celda =...

Macro para actualizar datos deficheros asignados por una tabla

Agrega al principio de tu macro esta instrucción: Application.DisplayAlerts = False Quedaría así: Rem Attribute VBA_ModuleType=VBAModule Option VBASupport 1 Sub crear_hojas() Application.DisplayAlerts = False Dim Lista As Range Dim iX As Long On...
Respuesta en y en 1 temas más a

Orden de un sector de una tabla

H o la: Puedes ejecutar la siguiente macro. Primero selecciona el área a ordenar, por ejemplo de A2:E6, en esa área deberá quedar fuera las líneas que no quieres ordenar, también debe quedar fuera el encabezado de la tabla. Sub Ordenar_Sector() '---...