Dante Amor

Dante Amor

Set h1 = Sheets("Hoja1") 'Hoja origen. Set h2 = Sheets("Hoja2") 'Hoja destino. Puedes utilizarlo
 2.852K puntos  Estado de México, México @aprendemos desde - visto
Preguntar

Preguntas y respuestas en Microsoft Excel

Copiar varias filas de una hoja a otra hoja

H o l a: Te anexo la macro para copiar Sub Copiar() 'Por.Dante Amor Application.ScreenUpdating = False Set h1 = Sheets("Hoja1") Set h2 = Sheets("Hoja2") u = h1.Range("B" & Rows.Count).End(xlUp).Row If u < 6 Then MsgBox "No hay datos a copiar" Exit...
Respuesta en y en 2 temas más a

Macro para hacer más ancha una columna al posicionarse en ella

H o l a: Pon la siguiente macro en los eventos de tu hoja Private Sub Worksheet_SelectionChange(ByVal Target As Range) 'Por.Dante Amor If Not Intersect(Target, Range("C:E")) Is Nothing Then Columns(Target.Column).ColumnWidth = 33.57 Else...
Respuesta en a

Insertar una fila en blanco si se da una condición

H o l a: Te anexo la macro para insertar una fila antes de la palabra "cambiar" Sub InsertarFila() 'Por.Dante Amor col = "J" For i = Range(col & Rows.Count).End(xlUp).Row To 1 Step -1 If Cells(i, col) = "cambiar" Then Rows(i).Insert Shift:=xlDown,...

Con un macro en Excel como puedo insertar una celda en blanco cada vez que encuentre una palabra especifica en una columna

H o l a: Te anexo la macro Sub InsertarFila() 'Por.Dante Amor col = "A" For i = Range(col & Rows.Count).End(xlUp).Row To 1 Step -1 If Cells(i, col) = "next" Then Rows(i + 1).Insert Shift:=xlDown, CopyOrigin:=xlFormatFromLeftOrAbove End If Next MsgBox...

Encontrar el último valor de una columna antes de la siguiente celda en blanco a partir de una fila concreta

H o l a: Te anexo la fórmula para que la pongas en la celda J6 =SI.ERROR((INDIRECTO("U" & COINCIDIR(999999999999;INDIRECTO("U"&FILA()&":U"&65000;1))+FILA()-1) - INDIRECTO("S" & COINCIDIR(999999999999;INDIRECTO("U"&FILA()&":U"&65000;1))+FILA()-1));"no...

Cambiar Valores por Iconos en Excel

H o l a: La fórmula en la la celda J8, VERDADERO, va sin comillas, ya que es un operador lógico, es por eso que no va entre comillas. =SI(K8=VERDADERO;1;0) El formato condicional: En se aplica a, debe quedar así: ' : ) 'S aludos. Dante Amor. Recuerda...
Respuesta en y en 3 temas más a

Macro copia y pega transpuesto un rango de filas variable.

La macro funciona si en la hoja 1 tienes encabezados en la fila 1: En la hoja2 el resultado quedará así: La macro: Sub CopiarTranspuesto() 'Por.Dante Amor Application.ScreenUpdating = False Set h1 = Sheets("Hoja1") Set h2 = Sheets("Hoja2")...
Respuesta en y en 3 temas más a

Macro copia (rango variable) y pega transpuesto

H o l a: Entiendo que los datos en la hoja empiezan en la fila 2. Te anexo la macro Sub CopiarTranspuesto() 'Por.Dante Amor Application.ScreenUpdating = False Set h1 = Sheets("Hoja1") Set h2 = Sheets("Hoja2") h2.Cells.Clear h1.[A1:B1].Copy h2.[A1]...
Respuesta en a

Editar macro vba Excel para inserción

Carga las 2 páginas en el combo Sub CargaCombobox2() With ComboBox1 .Enabled = True 'carga nuevamente el combo con los nuevos registros .Clear For i = 11 To 46 'Range("B" & Rows.Count).End(xlUp).Row 'original ("B" If Cells(i, "B") <> "" Then .AddItem...
Respuesta en a

Macro VBA Excel Insertar en la página 1 o 2

Te anexo la macro al presionar en el check Private Sub CheckBox2_Click() 'Act.Por.Dante Amor Dim i ' 'Si está activo el check de datos de identificación, entonces es para modificar los datos de identificación If CheckBox1 And CheckBox2 Then TextBox6...