Dante Amor

Dante Amor

Feliz mes del niño. Disfruta de la vida como niño!
 1.877K puntos  Estado de México, México @aprendemos desde - visto
Preguntar

Preguntas y respuestas en Microsoft Excel

Respuesta en y en 3 temas más a

¿Cómo copiar o filtrar datos de una celda a un LISTBOX, según TEXTBOX? VBA

Hola: Agregué el siguiente código a tu formulario: i = ListBox2.ListCount ListBox2.AddItem ActiveCell.Offset(0, 1).Select ListBox2.List(i, 0) = (ActiveCell.Value) ActiveCell.Offset(0, 1).Select ListBox2.List(i, 1) = (ActiveCell.Value)...

Como guardar datos desde un formulario con varios texbox y un combobox

Hola: Esta pregunta es similar a lo que te envié. Si es así esta sería la macro: Private Sub CommandButton1_Click() 'Act.Por.Dante Amor For Each h In Sheets If ComboBox1 = h.Name Then existe = True Exit For End If Next ' If existe = False Then MsgBox...
Respuesta en a

Como hacer una búsqueda en excel

Hola: Para realizar búsqueda te anexo la opción con la siguiente fórmula =INDICE(matriculas1!$C$1:$C$19,COINCIDIR(J2&K2,matriculas1!$A$1:$A$19&matriculas1!$B$1:$B$19,0)) La fórmula es matricial para aceptarla tienes que presionar las 3 teclas al...

¿Cómo hacer que los datos de listbox se guarden en una sola celda de excel con salto de línea?

Hola: No entendí bien cómo quieres pasar los datos a la celda. Puedes poner 2 imágenes, 1 para ver cómo tienes los 4 listbox En otra imagen pon cómo quieres los datos en la hoja de excel, procura que se vean las filas y las columnas de excel. Saludos
Respuesta en a

Como utilizar Mostrar - ocultar botón excel según valor de celda

Hola: Esta fórmula que pusiste está incorrecta: =si(a2>20;a1="si";0) Debería ser así: =SI(A2>20;"si";0) En tal caso la macro debería preguntar por el valor de la celda A2. No sé cómo tienes la macro, pero en donde día A1, deberás poner A2, por...

Buscar el valor máxima de una columna en función de un rango especifico de otra columna

Hola: En la foto que pusiste no se ven las filas y las columnas, así que te pongo una imagen de cómo supongo que tienes los datos: Pon la fórmula, por ejemplo en la celda H4 =MAX((C2:C14>=I2)*(C2:C14<=K2)*F2:F14) NOTA: La fórmula es matricial para...
Respuesta en a

Macros Excel para Eliminar botón

Hola: Si quieres guardar el archivo sin macros: Sub GuardaSinMacros() 'Por.Dante Amor Application.ScreenUpdating = False Application.DisplayAlerts = False Set l1 = ThisWorkbook ruta = l1.Path & "\" nombre = "Nombre" ' l1.SaveCopyAs ruta &...
Respuesta en y en 1 temas más a

Macro para deshacer cambios en al hoja

Hola: Te anexo las macros, prueba cuál es la que necesitas en cada botón Sub deshacer() ' Application.Undo End Sub Sub hacer() SendKeys "^y", True DoEvents End Sub Sub ControlZ() SendKeys "^z", True DoEvents End Sub Saludos
Respuesta en a

Como corregir un valor decimal en excel

Hola: Prueba con la fórmula Redondear =REDONDEAR(F12,0) Saludos
Respuesta en y en 2 temas más a

Macro para poner hipervinculo buscando un archivo con el nombre de una celda

Hola: Puedes explicar lo que necesitas con un ejemplo, utiliza imágenes para explicar tu ejemplo. Saludos