Variación Porcentual

Espero que me puedan ayudar con esto. Tengo un programa financiero que hace análisis vertical y horizontal, ahora cuando uso variación, la calculo con la siguiente fórmula
=SI(C31=0,0,(E31-C31)/C31) donde c es año o y e el año 1, la cosa es que si c es negativo, (una pérdida por ejemplo), la variación cuando E es positiva me sale negativa, comp puedo entonces recalcualr una variación paraque cuando el año cero sea negativo la variación salga como es, positiva
Gracias
1

1 respuesta

Respuesta
1
Hola, a ver si te sirve una de estas 2 funciones:
=SI(C31<0;((-1)*(E31-C31)/C31));SI(C31=0,0,(E31-C31)/C31))
=SI(C31<0;((-1)*(E31+C31)/C31));SI(C31=0,0,(E31-C31)/C31))
Un saludo,
Ramon

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas

Usar botón de comando para bajar línea

2 respuestas - Hola, quiero introducir los datos en una factura desde un formulario, pero...

Como hacer que una fila con datos cambie de color el texto si la primera celda de esa fila tiene un texto determinado

2 respuestas - Por ejemplo si la celda A5 dice "Partida" que esta y las demás celdas de...

Manejo base de datos excel

1 respuesta - Buenas tardes, tengo una nueva duda. Tengo dos hojas de excel con distintos...

Macro para encontrar faltantes de una serie

2 respuestas - Hola expertos: Necesito una macro que me permita recorrer una columna que...

¿Cómo copiar o filtrar datos de una celda a un LISTBOX, según TEXTBOX? Visual Basic

1 respuesta - Hola Dante, aquí te pregunto de nuevo, tal y como me lo dijiste. Mientras...

BuscarV al modificar una celda

1 respuesta - Estimados, tengo una base de datos, que quiero automatizar por lo tanto...

Userform o macro para buscar todos los datos de un cliente solo con el numero de CI, que están almacenados en una base de datos.

2 respuestas - Hasta el momento tengo este formulario, lo que necesito es que al ingresar...

Como Programar un Label en un Formulario para que ejecute una resta

2 respuestas - Para Dante Hola Amigo tengo una consulta tengo un formulario que niene dos...