Excel 2010 - Numero de veces que se repite una palabra en un rango de fechas

Respuesta de
a
Usuario

Buen Dia
He invertido mucho tiempo y no me sale. Agradezco me ayuden
con la siguiente tarea:
Necesito saber la formula para hallar el numero de veces que
se repite una palabra en un rango de fechas.
Lo que tengo:
En la “hoja 1”, en la columna “A1” a “A100” tengo una seria
de “fechas”, En la columna “B1” a “B100” tengo seis Nombres de productos que se
repiten en desorden (lápiz, papel, borrador, esfero, tijeras. Marcador).
Lo que quiero hacer:
En una “hoja 2” en la que haya un listado con los seis
productos, cada uno en una celda desde “A1” hasta “A6”, en la celda “D1”
pretendo poner la fecha en la cual inicia el rango, en la celda “D2” pretendo
poner la fecha final en la cual termina el rango.
Lo que quiero hacer es que al poner manualmente un rango de
fechas, saber cuantas veces se repite cada nombre en dicho rango, por ejemplo si
elijo el rango de fecha del “15 de Enero” al “18 de marzo” que se imprima al
frente de cada producto (es decir en la columna “”B1” a “B6”) el numero de veces
que se repite cada palabra en dicho rango de fechas.
Estoy utilizando la formula de “Contar.si()”, mezclado con “si()”
pero no me da, ultimo recurso fue utilizar la función “Contar.si.conjunto()”,
sin embargo siempre me genera error. Agradezco me ayuden compañeros.

Avatar
Experto

Hola, te mando una solución:

 

=contar.si.conjunto(A1:A100;">=15/1/2012";A1:A100;"<=18/3/2012";B1:B100;"papel")
 

 

recuerda finalizar la consulta por favor

un saludo,

Usuario

Compañero Luis móndelo mil gracias por su formula, funciona muy bien. Agradezco
el tiempo que empleo en ayudarme.
En tu formula en vez de la fecha se podría poner  ">=15/1/2012" se podría poner ">="&G24,
en donde G24 seria la fecha desde la cual requerimos los datos.
Encontré esta otra forma que también sirve, probada en Excel 2010
La escribo para que haya dos alternativas,
La formula es:
=SUMAPRODUCTO((Hoja1!$A$1:$A$100>=Hoja2!$D$1)*(Hoja1!$A$1:$A$100<=Hoja2!$E$1)*(Hoja1!$B$1:$B$100=Hoja2!A1))
Gracias nuevamente, y espero estas respuestas le sirvan a muchos mas.
Saludos Cordiales