Sumar celdas de varias hojas

Tengo que sumar diferentes celdas de varias hojas siempre están en la misma columna y linea en todas las hojas, el problema está en que el archivo me esta creando por medio de un macro hojas nuevas, ahora tengo la siguiente fórmula:
=SI((B35<>"");SUMA(¡hoja1:hoja20!K35);FALSO),
Pero en cuando me inserta la macro la hoja 21,(al final)ya no la suma.
Que fórmula o macro puede ser para que me sume todas las hojas independiente de el numero de hoja.

1 respuesta

1
Respuesta de
Hola rlucia:
Lo que te puede resolver el problema es que tengas fijas dos hojas digamos la hoja con el nombre "inicio" y la hoja con el nombre "final"; y que cuando agregues una nueva hoja con tu macro, la coloques entre estas dos
Sheets.Add Before =: Sheets("final")
Teniendo esto, solo modifica tu fórmula de suma para que lo haga de "inicio" a "final".
Elías
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje