Valores repetidos

Hola Fernando,
Resulta que quise aplicar esta respuesta tuya a oro compañero y no me funciono. A todos los valores que le indico me dice que ya fueron ingresados (por que así dice el mensaje que especifique el la solapa para este fin.
Sería posible además que los valores repetidos sean coloreados con formato condicional, esto para los datos que ya ingrese desde hace varios semanas.
"Selecciona el rango de celdas, donde cargarás los nombres (por ejemplo A37:A144
Clickea en "Datos" | "Validación". Aparecerá el cuadro de diálogos de
Validación.
En la solapa "Configuración busca en el menú descolgable de "Permitir" la última opción "Personalizada".
Se habilitará un cuadro de texto, abajo, donde podrás ingresar una fórmula como la siguiente:
=CONTAR.SI($A$37:$A$144,A37)<2
Agradezco de antemano tu tiempo y ayuda.
Oscar

1 respuesta

1
Respuesta de
Hola, Oscar!
Digamos, primero, que este tipo de validación de datos se entiende para datos A INGRESAR, no para datos ya ingresados.
Con esta idea en mente, deberías controlar que el rango donde quieres colocar esta validación sea *exactamente* el que incluyes en la fórmula de validación. En esta, asegúrate que el rango de control sea absoluto, es decir que esté anclado usando el signo $ para fijar filas y columnas.
En cambio, la dirección de la celda donde efectúas el control es relativa (no tiene signo $ en ella)
Finalmente, ten presente que debes seleccionar todo el rango *antes* de ejecutar los comandos de Datos | Validación, todas las celdas seleccionadas contendrán ese control y en caso de que el conteo supere a dos, emitirá un mensaje de error.
---
Si el rango contara ya con datos repetidos y quieres que se coloreen aquellas celdas con datos que estén más de una vez, selecciona el rango de números y elije "Formato condicional..." que se encuentra debajo de la opción "Formato" del menú principal.
Cuando la activas -habiendo seleccionado previamente el rango donde quieres aplicarlo- una pantalla de diálogo te pedirá que ingreses la condición.
Esta puede ser evaluada sobre la misma celda (Valor de la celda) o sobre otra celda distinta a la actual -como en tu caso- (Fórmula).
Supongamos que seleccionas el mismo rango que usamos para la validación de datos ($A$37:$A$144) y quieres que tengan un fondo amarillo aquellas cuyo valor está repetido.
Selecciona ese rango y elige la opción Fórmulas y en la casilla siguiente ingresa esta:
=CONTAR.SI($A$37:$A$144,A37)>1
(Nota que es muy similar a la usada en la validación)
Luego presiona el botón "Formato" y busca la solapa de "Tramas" y elige el color amarillo de la paleta. Presiona Aceptar para volver a la pantalla anterior.
De esta manera habrás definido la condición para TODAS las celdas seleccionadas.
Una vez asignado el color, clickea en Aceptar para cerrar esta ventana de diálogo y aplicar el formato a las celdas.
Tratándose de un formato, podrás copiarlo a otras celdas como cualquier otro formato de celda.
Para cualquiera de las dos funciones, es fundamental que tengas cuidado en seleccionar to el rango a afectar desde la celda superior hasta la última. En mi ejemplo -y sólo es un ejemplo- es A37:A144, pero puedes cambiarlo seleccionando otro rango y aplicando la fórmula con referencia a la dirección de la primera celda de tal rango.
Espero que con esto puedas lograrlo.
Si no, pregúntame de nuevo.
Un abrazo!
Fernando
Fernando,
Es cierto, seguro omití anteriormente lo de señalar el rango primero, funciono perfectamente, gracias a tu colaboración mi trabajo se ha vuelto más fácil y placentero. Mil gracias.
Oscar
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje
¿No es la respuesta que estabas buscando? Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: