Fórmula comparativa

Hola fernando, espero que me puedas ayudar con esto. Tengo un programa financiero que hace análisis vertical y horizontal, ahora cuando uso variación, la calculo con la siguiente fórmula
=SI(C31=0,0,(E31-C31)/C31) donde c es año o y e el año 1, la cosa es que si c es negativo, (una pérdida por ejemplo), la variación cuando E es positiva me sale negativa, comp puedo entonces recalcualr una variación paraque cuando el año cero sea negativo la variación salga como es, positiva
Gracias

1 respuesta

1
Respuesta de
Hola, Mauricio!
Utiliza esta fórmula donde el denominador de la fórmula prescinde del signo:
=SI(C31=0,0,(E31-C31)/ABS(C31))
Si se produjera el caso contrario (que E31 sea negativo) esta misma fórmula te arrojará una variación también negativa.
Creo que esto resuelve tu problema.
Un abrazo
Fernando
pd: Tengo en estudio tu otra pregunta, pero entenderás que su complejidad me demandará algo más de tiempo para resolverla. Un poco (más) de paciencia...;)
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje