Rellenar quiniela aleatoriamente

Hola a todos.
Mi duda es como hacer para que Excel rellene aleatoriamente los 1 de las quinielas. Me explico:
Quiero introducir yo en una celda el número de 1 que debe haber en las 15 filas. Después de eso Excel tiene que coger el número de unos que yo le haya indicado y repartirlos de forma aleatoria en las 15 filas.
Por ejemplo, yo pongo en una celda que quiero 6 unos y quiero que Excel me los coloque en la columna 3, la 4, 6, 7, 10 y 15. Tiene que colocar 6 y en las fila que "él" quiera...
No sé si me he explicado demasiado bien!
Gracias =)
1

1 respuesta

1
Respuesta de
Suponiendo que el número de unos estuviese en D1, en A1:A15 pon la fórmula:
=ALEATORIO()
En B1:B15:
=K.ESIMO.MENOR($A$1:$A$15;FILA())
En C1:
=SI(COINCIDIR(B1;$A$1:$A$15;0)<$D$1;1;&quot;&quot;)
Si copias y pegas esta fórmula en C2:C15, en la columna C aparecerán el número de unos indicado en D1, distribuidos aleatoriamente.
Ten en cuenta que la distribución de unos cambiará cada vez que Excel haga un recalculo, puesto que se recalcularán las celdas que tienen la función ALEATORIO.
Saludos.
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje
¿No es la respuesta que estabas buscando? Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: