Comparar horas en excel

Hola, a ver si alguien me puede ayudar, necesito comparar las horas de entrada de mis cajeros con la apertura real de la tienda, es decir, la tienda tiene que estar abierta a las 8:30 y él la abre por ejemplo a las 8:35 por lo tanto quiero que excel me diga esta diferencia como -0:05mins que ha tardado en abrir pero no lo consigo de ningún modo, me podéis echar una mano, gracias:)
1

1 respuesta

1
Respuesta de
Buenas tardes amigo:
Suponiendo que en A2 tienes la hora de apertura de la tienda y en B2 la de apertura de la caja, puedes sacar la diferencia restandolas, si suponemos que la diferencia estará en C2 en esa misma celda escribe:
=B2-A2
Y listo, tendrás la diferencia, asegurate que el formato de esa celda sea la misma que el de las horas que están en A2 y B2.
Espero sea lo que necesitabas
¿Te Funciono?
Recuerda finalizar la pregunta.
Perdón, pero estaba de vacaciones y no tenía internet disponible, la cosa es que sí que he probado esta fórmula mucho antes pero lo que pasa es que si abre antes, como p.ej tiene que abrir a las 10:00:00 y abre a las 9:12:06 me da una diferencia de 23:12:06 y en realidad son 48 mins antes y con esto no me apaño, no sé qué hay que hacer para que me lo cuente bien, a lo mejor tengo que poner una IF(...) pero no sé qué función poner, es que me rompo la cabeza con esto
Eso es otra cosa... Prueba con la siguiente fórmula en C2:
=SI(B2>A2;B2-A2;SI(B2<A2;A2-B2;0))
Suponiendo que en A2 tienes el valor de 10:00 y en B2 el valor de la hora real en que abren.
Espero sea lo que necesitabas.
Me da error en la fórmula, pero creo que es por el formato, en cuanto tenga un hueco te lo digo si me ha funcionado
Sigue dando el error, los formatos están bien pero me dice que la expresión B2>A2 es errónea!
Enviame el archivo a javier@mitrotti.com para validar.
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje

Más respuestas relacionadas

¿No es la pregunta que estabas buscando?
Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: