¿Cómo validar una matriz con otra matriz?

Hola,
Necesitaría ayuda con una fórmula. Tengo una matriz con las salidas generadas por una empresa. Esta matriz verifica los costos por día de la matriz de costo y graba la transacción como sigue:
Matriz de transacciones:
Item Depósito Día Costo
12702       501             01/01/10             546987
12702       501             01/01/10             546987
12702       506             01/01/10             45538
12702       509             01/01/10             488521
12702       501             02/01/10             98721
2 501 01/01/10  85247
Y tengo otra matriz la cual día a día actualiza los costos que se cargarán en la matriz anterior:
Matriz de costo
Item          Depósito     Día                      Costo
12702       501             01/01/10             25468
12702       506             01/01/10             528963
12702       509             01/01/10             263548
12702       501             02/01/10             856345
2               501             01/01/10             448632
El problema es que se cargaron mal los costos, por lo que todas las transacciones de la empresa se valuaron mal.
Necesito actualizar los costos en la matriz de costos.
Ahora viene la ayuda con la fórmula:
La matriz de transacciones tiene que recorrer la matriz de costo y traer el costo correcto (de la matriz de costo), validando el ítem, depósito y día.
Me ayudarías muchísimo con este tema, ya que a fin de año se necesita verificar la ganancia o pérdida de la empresa y esto la está afectando.
Desde ya muchísimas gracias si puedes ayudarme.
Saludos
Facundo
1

1 respuesta

Respuesta
1
Te subo un ejemplo, la fórmula es matricial, se confirma con Ctrl+Mayusc+enter.
Saludos.
http://www.megaupload.com/?d=ZZM8MV0I
Utiliza mejor esta fórmula en el archivo que te mande, no es matricial y consume menos recursos.
=SI(SUMAPRODUCTO(--(A$8:A$11&B$8:B$11&C$8:C$11=A1&B1&C1))>=1;D8;"")
Mil gracias! Me quedo con el primer ejemplo, el segundo que es más corto fija el campo costo.
Sin embargo deseo insertar dos líneas en el ejemplo (para agregar títulos) y si bien la fórmula continúa y se refresca, no traer ninguna información, aún presionando Ctrl+Mayusc+enter.
¿Qué podrá ser?
Saludos
Facundo
Si me puedes mandar un pequeño ejemplo de como quieres que te quede y donde, quizzas lo pueda ver mejor.
Listo, envié el ejemplo al mail.
Saludos y mil gracias!
Mil Gracias! No solo experto en excel, sino que además buena persona. Has respondido con una solución no solo correcta sino que también rápido!
Felices fiestas!
Facundo

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas