Color celda según condición

Hola todo expertos, necesito cambiar el color de una celda en función a una condición, en una planilla de exel, lo que tengo es
si en b3 dice 1 que a1:i12 se pinte en amarillo,
si en b3 dice 2 a1:i12 se pinte en celeste,
si b3 dice 3 a1:i12 se pinte en naranja,
si b3 dice 4 a1:i12 se pinte en verde,
si en b3 dice 5 a1:I12 se pinte en azul,
En la actualidad lo tengo con formato condicional pero en excel 2003 se me acabaron las opciones para seguir agregando condiciones, hay alguna forma de resolver esto.
Saludos
{"lat":-53.80234895064,"lng":-67.6643979549408}
1

1 respuesta

1
Respuesta de
Hola
Solo se puede con macros
Pega este código en la hoja que quieres que se ejecute
'cambia color rango segun valor celda
Private Sub Worksheet_Change(ByVal Target As Range)
    If [B3] = 1 Then
    Range("A1:I12").Select
Selection.Interior.ColorIndex = 6 ' amarillo
End If
If [B3] = 2 Then
    Range("A1:I12").Select
Selection.Interior.ColorIndex = 8 ' celeste
End If
If [B3] = 3 Then
    Range("A1:I12").Select
Selection.Interior.ColorIndex = 45 'naranja
End If
If [B3] = 4 Then
    Range("A1:I12").Select
Selection.Interior.ColorIndex = 4 ' verde
End If
If [B3] = 5 Then
    Range("A1:I12").Select
Selection.Interior.ColorIndex = 5 ' azul
End If
 Range("B3").Select
   'si 6 ó mayor sin relleno
   If [B3] >= 6 Then
   Range("A1:I12").Select
   Selection.Interior.ColorIndex = xlNone 'color de relleno sin color
Range("B3").Select
End If
End Sub
Si no sabes como dímelo y te lo explico
Saludos
Hola todo experto, la macro funciona a la perfección, pero en la actualidad el valor de b3 surge por una fórmula de búsqueda (=BUSCARV(C1;Hoja2!A1:B18;2;0), en cuanto le asigno esta fórmula se selecciona la referencia a1:i12 pero no se pinta, ¿se puede solucionar este problema?
De todos modos muchísimas gracias.-
Saludos
Cambia la primera linea del código por esta otra
Private Sub Worksheet_Calculate()
Con eso te debe funcionar cuando cambie el valor de la fórmula
Si te sirve cierra la pregunta
Saludos
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje
¿No es la respuesta que estabas buscando? Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: