Saber si un valor se encuentra en una columna

Buenas,
Necesito que en la celda C59 me aparezca "SI" si en el rango G31:G54 se encuentra el valor 12200 (lo pongo en la celda C58) y así con otros 2 valores más situados respectivamente en las celdas D58 y E58.
He probado con la función BUSCAR de estas dos formas pero no me funcionan bien en los tres valores:
=SI(ESERROR(BUSCAR(C58;$G$31:$G$54));"";SI(BUSCAR(C58;$G$31:$G$54);"SI";""))
=SI(ESERROR(BUSCAR(C58;$G$31:$G$54));"";SI(BUSCAR(C58;$G$31:$G$54)=C58;"SI";""))
No sé si es un problema de que esta función necesita datos ordenados, en cuyo caso en la columna G31:G54 los datos no pueden estar ordenados por lo que entonces necesitaría otra fórmula que permitiera tomar datos desordenados.
Gracias de antemano.

1 respuesta

1
Respuesta de
Hola,
En Datos - Validación - Configuración - Permitir - Personalizada, en el cuadro de fórmula le escribes:
=O(Y(A1>=0;A1<=9999;A1<>2);Y(ESTEXTO(A1);LARGO(A1)<>4))
Con esto podrás poner cualquier número entre 0 y 9999 menos el 2, o cualquier texto de longitud distinta de 4.
Un saludo
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje
¿No es la respuesta que estabas buscando? Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: