Asociar Datos entre Columnas de una Lista en Excel

Estimados, tengo una pregunta respecto al manejo de columnas y filas en excel. Lo que necesito es buscar en la columna fecha todas las que sean iguales y para ellos sumar el total de horas P y Horas extras para ese día. Vale decir algo muy similar a lo que se realiza con las tablas dinámicas, pero mediante VBA.
Adjunto ejemplo de la lista de ingreso y del resultado que debiese obtener...
La idea es generar un código que me permita ir buscando en la columna Fecha todas las entradas iguales y luego sumar en la Columna las Horas P y Horas Extras asociadas a ese día...
Lista de Ingreso.. Sería algo así..
Fecha HorasP Horas Extras
10-10-2010 0:00 3:00
10-10-2010 7:00 0:00
10-10-2010 3:00 7:00
10-10-2010 7:00 0:00
10-10-2010 1:00 3:00
10-10-2010 5:00 3:00
11-10-2010 3:00 6:00
11-10-2010 7:00 0:00
11-10-2010 2:00 7:00
11-10-2010 7:00 0:00
11-10-2010 4:00 7:00
12-10-2010 7:00 0:00
12-10-2010 4:00 7:00
12-10-2010 7:00 0:00
13-10-2010 5:00 3:00
13-10-2010 4:00 7:00
13-10-2010 5:00 3:00
Resultado sería algo como esto...
Resumen HorasP Horas Extras
10-10-2010 23:00 16:00
11-10-2010 23:00 20:00
12-10-2010 18:00 7:00
13-10-2010 14:00 13:00
Me podrían echar una mano..
Gracias..

1 respuesta

1
Respuesta de
Hola,
Puedes hacer uso de la función SUMAR.SI. Te pongo un ejemplo:
                     a                           b                     c
17         FECHA                HORAS P.               HORAS EXTRA
18         10/10/2010           10:00                         5:00
19         11/10/2010             5:00                         3:00
20         10/10/2010             4:00                         0:00
21         10/10/2010             3:00                         1:00
22
23         10/10/2010            17:00                        6:00
La fórmula para B23 es: =SUMAR.SI(A18:A21;A23;B18:B21)
y la fórmula para C23 es:  =SUMAR.SI(A18:A21;A23;C18:C21)
Para la fecha 11/10/2010, si la colocamos en A24, cambiaríamos en las fórmulas donde pone A23 por A24.
Un saludo
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje