Sumar días hábiles a una fecha

Respuesta de
Usuario
Hola
Espero ser claro con mi pregunta, la cual es la siguiente:
* pongo una fecha inicial (en C2)
* Pongo un numero x (en H2)
* Necesito la suma de la fecha C2 + el numero de H2 y resultado en I2 (fecha de vencimiento)
Aclaración:
1. Debe sumar a partir del día siguiente
     ejemplo 28/09/2010 + 2 = 30/09/2010
2. En la suma no debe incluir los domingos ni dias festivos (SI sábados)
     ejemplo 28/09/2010 + 5 = 4/10/2010 (no se contabilizo domingo)
Nota: se supone que la función debo hacerlo en I2 (con los datos de C2 y H2), por favor quisiera que fuera un poco detallado ya que mi conocimiento en excel es muy básico.
Gracias de antemano cualquier respuesta que me pudieras dar.
Pablo
Avatar
Experto
Tendrás que hacer un esfuerzo, porque la solución no es tan básica.
-
En Hoja2
-
Desde A1 hasta A365, haz una lista con todos los días del año, sin omitir ninguno.
Desde B1 hasta B365, teclea 1 en los días que SI SON HÁBILES y 0 en los que NO LO SON.
C1=B1
C2=B2+C1
Selecciona C2 y copia {ctrl}+{c}
Selecciona C3 hasta C365 y pega {ctrl}+{v}
Selecciona A1 hasta A365 y copia {ctrl}+{c}
Selecciona D1 hasta D365 y pega {ctrl}+{v}
Selecciona A1 hasta C365, y en el cuadro de nombres escribe FESTIVOS
Selecciona C1 hasta D365, y en el cuadro de nombres escribe RESULTADOS
-
En la Hoja1
-
I2=CONSULTAV(CONSULTAV(C2,FESTIVOS,3,FALSO)+H2,RESULTADOS,2,FALSO)
-
Prueba y comenta.
Usuario
Hola,
me parece que hice todo lo que dice en la respuesta, pero capaz algo he omitido
Ahí te estoy mandando a tu correo (), el libro de prueba haber si me das una mano, también en la columna H los plazos son por días, pero a veces solo son por horas, si puedes sugerirme algo al respecto, te lo agradecería, en todo caso no me hago problemas por que si son por horas lo pondré o nomas.
Gracias
Avatar
Experto
Creo que tenemos un conflicto de versiones. En lugar de CONSULTAV utiliza BUSCARV; resulta que para el Office 2007 la función cambió de nombre. La fórmula quedaría de la siguiente manera:
-
=buscarV(buscarV(C6,FESTIVOS,3,FALSO)+H6,RESULTADOS,2,FALSO)
-
Saludos
Usuario
Gracias,
era solución que buscaba,
gracias nuevamente por tu tiempo