¿Cómo programar vlookup en una macro?

Hola!
Necesito pls que me ayuden a programar una macro para que en una columna de la hoja1 ponga el resultado de un vlookup, la lista llega a las cinco mil filas.
Entonces la base de datos donde necesito que el buscarv haga la búsqueda esta en la hoja2, obviamente la fórmula normal de buscarv me da error.. me ayudan pls a entender como se construye.
Gracias

1 respuesta

1
Respuesta de
Hola:
¿Por qué 'obviamente' la fórmula normal de BUSCARV te da error? No tiene porqué, seguramente la estás escribiendo mal.
Te dejo 1 ejemplo:
Dato en A2 de la Hoja1
Rango en A2:H100 de la Hoja2
Col a devolver: col C (es decir, col 3 del rango)
Falso: para que te devuelva la coincidencia exacta:
=BUSCARV(A2;Hoja2!A2:H100;3;falso)
Estoy utilizando pto y coma como separador, quizás tu libro utilice solo coma... verifícalo y ajústalo
Sdos. No dejes de comentarme si ahora sí la función resuelve tu consulta.
Elsa
http://aplicaexcel.galeon.com/manuales.htm
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje
¿No es la respuesta que estabas buscando? Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: