Macro excel visual basic

Cordial Saludo
Después de hacer algunas consultas en internet cree la siguiente macro:
Function HolaMundo(Sistema As String) As String
If Sistema = "S10" Then
HolaMundo = "SALA NORTE"
End If
If Sistema = "S12" Then
HolaMundo = "SALA CALIMA"
End If
End Function
Function HolaMundo2(Sistema As String) As String
If Sistema = "S10" Then
HolaMundo2 = "CALI"
End If
If Sistema = "S12" Then
HolaMundo2 = "CALI"
End If
End Function
Básicamente lo que hace es basado en un código alfanumérico por ejemplo S12, define una sala y una ciudad, las cuales se ubicaran en 2 casillas diferentes.
Ahora Me gustaría saber el código más eficiente de esto pues resulta ser bastante pesado, ya que son mucho más ciudades y salas,.
Por otra parte extrarer información automáticamente de otro libor de excel con tan solo un botón, y ademas que se creen automáticamente las 2 columnas las cuales contengan esta fórmula para que todo sea automático.

1 respuesta

1
Respuesta de
Hola:
Lo que se me ocurre es 1 solución 'sin macros'... porqué no escribís la misma lista que estás colocando en el Editor, en alguna hoja y utilizas luego la función BUSCARV...
Por ej, col A los códigos, col B las salas y col C el otro dato. Luego la fórmula será:
=BUSCARV(A3;Hoja2!A2:C100;2;falso)   
Esto te devolverá la sala, cambiando el argumento '2' por '3' te devolverá la ciudad.
Sdos
Elsa
http://aplicaexcel.galeon.com/funciones.htm
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje