Macro buscar valor en otra hoja

Respuesta de
a
Avatar
Usuario
Buenas,
No manejo mucho de VBA y me gustaría que me echases una manilla si es posible, necesito una macro que me busque si hay valores de la columna 1 de la HOJA que estén en la columna 1 de la HOJA 2 y que en el caso que este me ponga SI en la columna 3 de la HOJA 1. Agradecería me ayudases.
Un saludo y muchas gracias de antemano.
Avatar
Experto
En la celda C2 pon la siguiente fórmula:
=SI(ESERROR(BUSCARV(A2;Hoja2!A:A;1;FALSO));"";"Sí")
No te pongo la fórmula para la fila 1 porque muchas veces se usa para poner cabeceras. Si en la línea 1 tienes también datos copia y pega la fórmula desde C2 y arreglado.
Un saludo
Avatar
Usuario
Muchas gracias, es perfectamente lo que quería. Me había cegado en conseguirlo con una macro y esta es mejor forma.
Un saludo.