Separar datos celdas

Hola muy buenas a todos:
Tengo apellidos y nombre en una misma celda y lo que me gustaría saber es si puedo separarlos y en dos celdas, una de apellido y una de nombre:
Tengo:
Martínez Lopez Juan
Y quiero:
Martinez Lopez Juan (en dos celdas distintas
Me pasa lo mismo con la fecha:
Tengo:
24/3/1979
Y necesito
24 3 1979 (en tres celdas distintas)
¿Se podría hacer? Muchas gracias

1 respuesta

1
Respuesta de
Si tienes el nombre en A1 puedes coger las dos primeras palabras (los apellidos) con:
=SI(ESERROR(ENCONTRAR(" ";A1));A1;SI(ESERROR(ENCONTRAR(" ";A1;ENCONTRAR(" ";A1)+1));A1;IZQUIERDA(A1;ENCONTRAR(" ";A1;ENCONTRAR(" ";A1)+1)-1)))
El resto del texto de la celda A1 (se supone que el nombre) lo obtendrías con:
=ESPACIOS(DERECHA(A1;LARGO(A1)-LARGO(B1)))
Para separar una fecha puedes hacer "=año(A1", "=mes(A1)" y "=dia(A1)"
Un saludo
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje