Fórmula en hoja excel no me reconoce valores en celdas

Hola, a todos soy nueva aquí y necesito ayuda sobre una fórmula. Resulta que tengo en la hoja 1 la siguiente fórmula; =SI(C50=MVD!$C$4:$C$53;MVD!$D$4:$D$53;SI(C50=MVD_SHOP!$C$4:$C$53;MVD_SHOP!$D$4:$D$53;SI(C50=P.Este!$C$4:$C$53;P.Este!$D$4:$D$53;SI(C50=Paysandú!$C$4:$C$53;Paysandú!$D$4:$D$53;"En depósito")))) la celda C50 estaría en la hoja 1. En principio estaba todo bien, pero cuando cambio los datos de lugar de las hojas"P.Este" por ejemplo, o cualquier otra, no me reconoce los valores cambiados. Por ejemplo se trata buscar los artículos que están en la hoja 1, los cuales son únicos, en cada una de las otras hojas, y al encontrarlos llevar a la hoja 1 el destino donde se encuentran, de forma que al mirar la hoja 1 se pueda saber que tal articulo está en P.Este o Paysandú, etc. El problema me surge que si los artículos entán en la celda C5 (por ejemplo) de la hoja P.Este y Paysandú (aunque sean artículos diferentes), no me reconoce el destino de una de las hojas, aunque de acuerdo a la fórmula no debería ser así.
En Hoja 1: Art. Destino si el art. 125 está en la celda D6 de P. Este y el
                     125 P.Este art. 126 está en la celda D6 de Paysandú,
                   126 Paysandú entonces no me reconoce el art. 126
Adjuntaría el archivo pero... no veo aquí la herramienta para hacerlo, e intentado pegar imágenes de las hojas excel para explicarme mejor pero no he podido. Espero haber explicado mi problema, y puedan ayudarme, sino trataré de explicarme mejor.
Gracias por la ayuda que me puedan dar.

1 respuesta

1
Respuesta de
Hola beruzca, me parece que estás utilizando la función equivocada; a mi criterio sería mejor si utilizaras la función =BuscarV().
=Si(EsNod(BuscarV(C50,MVD!$C$4:$D$53,2,0)),BuscarV(C50,MVD_Shop!$C$4:$D$53,2,0))
Bueno esto es un ejemplo para que lo adaptes.
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje