Sacar promedio (porcentaje) datos filtrados

¿Hola Christian, qué tal?
Vuelvo a estar "encallado"... Te comento... quiero sacar promedio de porcentajes de datos filtrados.
En la website de Todoexpertos he encontrado la siguiente fórmula, que he adaptado a mi proyecto:
=SUMAPRODUCTO((SUBTOTALES(3;DESREF(ANY2008!$A$6:$A$106;FILA($A$6:$A$106)-MIN(FILA($A$6:$A$106));;1)))*$L$6:$L$106)
La fórmula anterior suma ("negrita") los datos de la columna L, pero, en mi caso, necesito que haga un promedio de porcentajes (L6= 100%, L7=70%, L8=40%... y así hasta la fila 106 de la columna L), a partir de un autofiltro en la columna A.
He intentado, sin éxito otra vez!, sumar los porcentajes a partir de la fórmula anterior y me arroja el error #! VALOR¡. También, he intentado insertar la función PROMEDIO (L6:L106) y me arroja el error #!DIV/0¡..
¿Cómo se podría adaptar la fórmula anterior para hacer promedio de los datos de la columna L (porcentaje (%))?
De nuevo, gracias por tu ayuda y tiempo...!
Un saludo

1 respuesta

1
Respuesta de
Hola Jordserr!
¿Qué tal?. BUeno justo ahora he entrado 5 min solo para revisar mi bandeja de entrada y preguntas que estoy viendo que tengo que responder en estos días, entre los cuales esta el tuyo.
Veo la fórmula, aun no la pruebo porque precisamente necesito estar más calmado para probar y saber que sucede y verificar lo que me comentas del error.
No te preocupes que revisare tu caso. Alguna duda que tenga te aviso por este mismo medio.
Saludos
Christian
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje