Función en excel para encontrar contenido de una celda

Hola Experto,
Estoy intentando crear una fórmula pero me estoy frustrando, a ver si puedes ayudarme.
Necesito una fórmula que busque una palabra en el contenido de la celda, si lo encuentra, que aplique a la celda activa un valor; si no, que haga otra búsqueda y así sucesivamente con SIs anidados hasta finalizar.
Por ejemplo si la celda B1 contiene la palabra "Madrid", que en la celda a1 ponga un 1; si no, si la celda B1 contiene la palabra "Valencia", que ponga un 2; si no, si la celda b1 contiene la palabra "Barcelona", que ponga un 3; si no, que ponga un 0).
Muchas gracias por tu ayuda!

1 respuesta

-1
Respuesta de
Hola eso es imposible, la celda activa es la misma donde se está ejecutando la fórmula no puedes cambiar el valor de una celda con una fórmula que esta en la misma celda, eso es una referencia circular y es ilógico, además de imposible.
La única forma es hacerlo es con dos fórmulas para que te encuentre si la palabra Madrid esta en la celda A1 en la celda B1 pones esta fórmula:
=SI(ESNUMERO(ENCONTRAR("Madrid";A1));"VEREDADERO";"FALSO")
Y ahora en otra celda la que quieras cambiar pues pones otra fórmula que compruebe tu condición por ejemplo:
=SI(Y(B1="VERDADERO");"CORRECTO";"INCORRECTO")
>Un saludo
>Julio
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje
¿No es la respuesta que estabas buscando? Puedes explorar otras preguntas del tema Microsoft Excel o hacer tu propia pregunta: