Cómo puedo eliminar datos repetidos

Respuesta de
a
Usuario
Hola estoy haciendo mi servicio social y una de mis practicas es la eliminación de datos repetidos en una base de datos de 14 columnas y 51542 celdas, solo en una columna se repiten los datos, entonces tengo que eliminar de toda la base las celdas o filas de la A a la N los datos que se repiten enla colmna B, ¿cómo lo puedo hacer?
De antemano gracias espero su ayuda porque estoy por la calle de la amargura en esto de excel
Experto
Hola,
Sólo una pregunta, si tienes muchas columnas y los datos sólo se repiten en una de ellas, ¿cómo sabes cuáles filas puedes eliminar y cuál de todas las repetidas debes dejar?
 
Si la idea es eliminar las repetidas y dejar una cualquiera, pienso que puedes hacerlo siguiendo estos pasos:
1. Debes ordenar tu tabla (por el menú Datos / Ordenar...) tomando como columna para la ordenación la columna B (donde tienes los datos repetidos).
2. Ahora ya tienes todos los repetidos juntos, pues en una columna adicional (en la celda L2 por ejemplo) vas a escribir la siguiente fórmula:
=SI(B1=B2; ""; "X")
3. Copias esta fórmula hasta el final de los datos (hacia abajo).
4. En este momento tienes tu tabla ordenada y tienes marcado con "X" la última fila donde se repite el dato de la columna B.
5. Ahora puedes utilizar un autofiltro (del menú Datos / Autofiltro...) y filtrar con base en la nueva columna usando la opción filtrar los que sean igual a X.
6. Ahora tienes tu tabla sin repetidos. Puedes copiar esta tabla filtrada y pegarla en una nueva hoja y listo.
 
Espero que te sea de utilidad la información que te envío.
 
Saludos, Tavopz
Usuario
Contestando la pregunta solo los datos de la b se repiten son la clave de solicitudes de compra, las otras columnas no son iguales no se porque razón y lo que me pidieron es el numero de solucitudes sin repetición existen y debe incluir los otros datos porque se clasifican para análisis.
 
Pero de cualquier forma la solución que me propones ya la realice y me fue de ayuda
Gracias por tu tiempo