Sacar un promedio con excel

Buen día para todos. Quisiera que me colaboraran con lo siguiente: Tengo en una columna de excel varios valores numéricos. (Desde la G15 hasta la G500).. Todas las celdas tiene valores entre 1 y 25, pero hay algunas que tienen 0. Quiero sacar un promedio de todo el rango G15:G500 pero que no me tome en cuenta las celdas que tienen valor cero. ¿Cómo puedo hacer esto? Agradezc su colaboración. Muchísimas gracias... Andres.
4

4 respuestas

1
Respuesta de
=SUMA(G:G)/CONTAR.SI(G:G,">0")
Añade un comentario a esta respuesta
1
Respuesta de
Ojala pueda ayudarte
No se si exista en excel alguna opción que haga eso ... pero en ese caso a mi resulta muy bien hacer esto ...
=SUMA(G15:G500)/CONTAR.SI(G15:G500;">0")
Suerte
Añade un comentario a esta respuesta
1
Respuesta de
Tienes que dividir la suma de todos los números entre la cuenta de todos ellos menos la cuenta de ceros; es decir:
=sumatodos /(cuentatodos-cuentaceros)
o sea:
=SUMA(G15:G500)/(CONTAR(G15:G500)-CONTAR.SI(G15:G500;0))
Un saludo
Hola:
Por favor, finaliza la pregunta
Añade un comentario a esta respuesta
1
Respuesta de
Hola,
La verdad es que creo que existe una forma automática de hacerlo con excel, pero no recuerdo cual, por lo tanto te daré la solución sencilla.
=SUMA(G15:G500)/CONTAR.SI(G15:G500;"<>0")
De esta forma, el promedio que es la suma de los elementos dividido por el número de ellos, se dividiría sólo por aquellos que son diferentes de cero.
Saludos, Tavopz
Muchísimas gracias... la verdad no me función con "<>0" en lugar de eso coloque ">0" y así si me funciono.. pero gracias a tu respuesta pude dar con eso.. te quedo infinitamente agradecido.. muchísimas gracias...
Añade un comentario a esta respuesta
Añade tu respuesta
Haz clic para o
Escribe tu mensaje

Más respuestas relacionadas

¿No es la pregunta que estabas buscando?
Puedes explorar otras preguntas de los temas Microsoft ExcelTecnología e Internet o hacer tu propia pregunta: