Horas comunes y horas extra

Tengo que hacer una fórmula en una planilla de excel, o hacerlo con una macro (que no sé cómo, a pesar de saber programar en visual basic; digamos, no sé como las hago, como las "grabo", en fin, no entinendo) que haga lo siguiente: (pseudocódigo):
Desde celda tal hasta tal_otra
Si (valor en celda)<8
Acumula en un total
si (valor en celda)>= 8
Suma 8 al total
Fin si
Fin desde
¿Me explico? Cálculo de horas comunes. Otra función haría horas extras:
Desde celda tal hasta tal_otra
Si (valor en celda)>8
total=total+(valor en celda-8)
Fin si
Fin desde
Muchas gracias, me salváis el pellejo.
Angela
1

1 Respuesta

25.250 pts.
Ángela, ante todo siempre la sencillez. Aquí lo más fácil que puedes hacer es un par de fórmulas. Suponemos que el rango donde están las horas es E1:E11.
1ª Fórmula: Horas normales
=SUMAR.SI(E1:E11;"<=8")+CONTAR.SI(E1:E11;">8")*8
2ª Fórmula: Horas extraord.
=SUMA(E1:E11)-"Horas normales (donde estén)"
Yo creo que así te puede funcionar. Espero que te sirva.
Un saludo,

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas