Problema con acceso a internet

Hola, Estoy intentando realizar una conexión con un nuevo
proveedor de internet, pero no sé que problema hay, el caso es que me rechaza la conexión al llegar al punto de comprobar el nombre de usuario y el pass.
El proveedor en cuestión es Canarias Telecom y el nodo de
acceso es el siguiente número: 901082700.
Actualmente tengo 5 tipos diferentes de conexión, a saber:
Iddeo, Eresmas, Wol, Telepolis, y Teleline.
La verdad es que no estoy muy contento con la velocidad a
la que trabajan todos estos proveedores, pero consigo conectar con todos ellos. El sistema que empleo para conectarme con estos proveedores es el mismo, osea lanzo el pppd desde un script bash y cada uno con su correspondiente fichero "options", siendo este fichero igual en todos los casos, salvo naturalmente en los apartados
"connect" y "name"
--------------------------------------------------
connect /usr/sbin/chat -v "" ATW1DT901082700 CONNECT ""
crtscts
modem
passive
debug
name [email protected]
defaultroute
asyncmap a0000
/dev/modem
ipcp-accept-local
115200
noauth
noipx
---------------------------------------------------
Desde Windows me funcionó a la primera, pero desde Linux ya se me han agotado las ideas sobre que tendría que cambiar para poder conectar.
Si se te ocurre algo, quedaría agradecido port la ayuda.
Saludos.
1

1 respuesta

Respuesta
Lo único que se me ocurre, es que tu nuevo ISP utilice un protocolo de autenticación distinto. Aunque no mencionas cual usas ahora, hay 2 posibles: CHAP y PAP, es posible que estés usando el equivocado.
El manual del PPP, detalla cada una de las opciones de tu archivo connect. __
$ man pppd
La seccion Authenticacion, explica las diferencias entre CHAP y PAP.
_ _ _ _
Hola, ya he probado los dos modos de autenticación, PAP y CHAP y este es el log que me devuelve la conexión fallida.
Serial connection established.
using channel 3
Using interface ppp0
Connect: ppp0 <--> /dev/modem
sent [LCP ConfReq id=0x1 <asyncmap 0xa0000> <magic 0xecb254f9> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0xa0000> <magic 0xecb254f9> <pcomp> <accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0xa0000> <magic 0xecb254f9> <pcomp> <accomp>]
Hangup (SIGHUP)
Modem hangup
Connection terminated.
No sé si esto puede aclarar algo.
Gracias por tu ayuda.
Saludos
En realidad no ayudan mucho, si te fijas es tu maquina la que hace 3 intentos por enviar datos al servidor, y finalmente cuelga.
Creo que la mejor ayuda te la puede (y debe) brindar tu ISP, es posible que ellos tengan alguna configuración especial, que impide que tu modem pueda conectarse correctamente.
Para obtener más información que podría ser útil, conéctate con tu ISP, usando "minicom" o algún otro emulador de terminal. Mira el menu que te sale, e intenta conectarte manualmente, así podrías tener una mejor idea de lo que ocurre.
Cada RAS (servidor de acceso remoto) tiene su propio estilo de menu, y opciones, así que intentan dando ENTER (o CTRL-R) varias veces después de la conexión, y cuando obtengan un mensaje, utiliza "h", "help", etc. para conseguir algún tipo de ayuda y poder continuar.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas