Ejecutar macro desde función en excel

Respuesta de
a
Usuario
Hola, estoy tratando de ejecutar una macro desde una función SI. ´
=SI(A1<>"";macro1;"")... cómo hago para llamar esa macro? espero me puedas ayudar. Gracias.
Experto
Hola sol el YankeeXtm y tu respuesta a la macro de excel, la podes resolver de la sig. manera.
Anda, dentro excel a el menu herramientas, después a macros, después ingresa al editor de Visual Basic y escribí la siguiente sentencia:




Private Sub Worksheet_Change(ByVal Target As Range)
If A1 = "" Then MsgBox "Celda vacia"
End Sub

Salís del editor de VB y proba haber que pasa.