Página Ultradev

Hola Internick.
Estoy empezando con Ultradev y he construido un pequeño site desde el que quiero hacer consultas a una base de datos. He finalizado una parte y en mi máquina funciona usando el Personal Web Server, pero en el momento de colgarlo a un servidor (que soporta ASP) me da este error:
Tipo de error:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][Administrador de controladores ODBC] No se encuentra el nombre del origen de datos y no se especificó ningún controlador predeterminado
¿Podrías orientar-me sobre el problema? ¿El problema está en la conexión que he creado?
Gracias por adelantado.
1

1 respuesta

Respuesta
1
Con gusto te ayudo. Primeramente debes hacer la conexión ODBC en el panel de control escogiendo en DNS DEL SISTEMA Y DNS DEL USUARIO la base de datos con la que vas a trabajar. Ahora en el Ultradev debes crear un recordset editando la conexión que has creado.
Pero primeramente, ¿hiciste el trabajo en otra maquina y lo quieres pasar en otra maquina? Porque si es así es el típico error que te da cuando haces eso y lo que debes hacer es configurarla exactamente igual que en la maquina que realizaste el trabajo. Así es el ultradev!. Ahora para ayudarte de mejor manera, ¿qué tipo de conexión haces? ¿Una en la que recibes datos de la base o una en la que le envías datos a la base? Me dijiste una consulta y supongo que recibes datos de la base, entonces allí debes hacer un recordset pero debes hacerlo seleccionando no todos los campos de la base sino en el que quieres basar tu consulta.
Amigo, el Ultradev es un programa que te permite hacer fácilmente tus conexiones a bases de datos pero también da bastantes problemas porque te genera cantidad de código "basura" que ni te imaginas!.
Yo tuve el mismo problema que tu al terminar un trabajo en Ultradev y lo pase a tres maquinas diferentes y en ninguna corrió así que tuve que trasladar mi computadora. En dos de las maquinas en que las corrí tuve que darle F5 como loco al navegador y a las cansadas corría. Te agradecería me dieras más información acerca de lo que ya tienes hecho y lo que te falta que con gusto estaré atento para ayudarte y responderte lo más rapido posible!.
Internick!
Hola internick
Creo que el problema está en lo que tu comentas en tu primer párrafo de la respuesta. Supongo que tengo que configurar la conexión OBDC del servidor, pero no tengo ni idea de como. Lo mismo para la DNS del sistema (servidor) y la DNS del usuario.
En mi ordenador usando el Personal Web Server la página funcionaba correctamente, pero en el servidor no encuentra los datos.
puedes verla en www.inspiraweb.550m.com
Gracias otra vez.
He revisado la dirección que me diste y según lo que me di cuenta son varios errores y de dice las lineas en las que tienes lo errores, en una tienes un error en la linea 10, en otra en la 4 y así. ¿Amigo para ayudarte con el ODBC podrías decirme si trabajas con base de datos y con que base de datos trabajas? ¿En Access, SQL, etc? ¿Qué sistema operativo tiene tu servidor?, aquí estaré!.
Hasta pronto!
Internick!
Ayudame votando por cada respuesta que te doy. Seria increíble estar entre los primeros en Ultradev y poder ayudar y a la vez aprender más.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas