Netscape

Tengo una página en la que tengo unos botones (que tienen un efecto javascript) dentro de una tabla y lo que me pasa es que con internet explorer se ve la tabla donde yo la pongo mientras que con netscape me pone la tabla arriba del todo del frame, es decir, pasa de donde yo la ponga la pone donde el quiere te envío el codiogo iy le hechas un vistazo, gracias por todo:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML>
<HEAD>
<TITLE>ACR s.l. - Aire Acondicionado para Automoción</TITLE>
<META NAME="GENERATOR" CONTENT="MAX's HTML Beauty++ ME">
<LINK href="special.css" rel="stylesheet" type="text/css">
</HEAD>
<BODY BACKGROUND="imagenes\izquierdasinbotones.gif" LEFTMARGIN="4" RIGHTMARGIN="0" TOPMARGIN="130" BOTTOMMARGIN="0" MARGINWIDTH="0" MARGINHEIGHT="0" BACKGROUND="izquierdasinbotones.gif">
<SCRIPT LANGUAJE="JavaScript">
var VersionNav= navigator.appVersion
var star=null;
function AlternarImag (nombre, fuente) {
if (((navigator.appName == "Netscape") & (VersionNav.substring(0,1) >=3)) || (VersionNav.substring (0,1) >= 4)) {
imagen = new Object();
imagen = nombre;
imagen.src = fuente;
}
}
</SCRIPT>
<TABLE border=0 ALIGN="left" VALIGN="top" CELLPADDING=0 CELLSPACING=0>
<TR>
<TD>
<!-- Imagen 1 -->
<A HREF = "empresaframe.html" target="DERECHA" onMouseOver = "AlternarImag(img1,'quienessomos1.gif')"
onMouseOut = "AlternarImag(img1,'quienessomos.gif')">
<IMG NAME = "img1" SRC = "quienessomos.gif" WIDTH="103" HEIGHT="28" HSPACE="0" BORDER="0" ALIGN="middle"></A>
</TD>
</TR>
<!-- Imagen 2 -->
<TR>
<TD>
<A HREF = "productosframe.html" target="DERECHA" onMouseOver = "AlternarImag(img2,'productos1.gif')"
onMouseOut = "AlternarImag(img2,'productos.gif')">
<IMG NAME = "img2" SRC = "productos.gif" WIDTH="103" HEIGHT="29" HSPACE="0" BORDER="0" ALIGN="middle"></A>
</TD>
</TR>
</TABLE>
</BODY>
</HTML>
1

1 Respuesta

27.075 pts.
Antes de todo quiero pedir disculpas por haber tardado tanto, pero he estado muy ocupado últimamente.
Netscape y tablas es una ciencia aparte, es decir que Netscape casi nunca pone las tablas igual que Explorer. La solución es poner un poquito de CSS en tu linea donde declaras la tabla. Lo puedes hacer así:
Reemplaza lo siguiente:
<TABLE border=0 ALIGN="left" VALIGN="top" CELLPADDING=0 CELLSPACING=0>
con
<TABLE BORDER="0" ALIGN="left" VALIGN="top" CELLPADDING="0" CELLSPACING="0" STYLE=" position:absolute; left:10; top:100; width:103">
(Todo en una línea)
Este posiciona la tabla justamente donde tu quieres. Quizás necesitas ajustar los valores de left y top, pero eso ves mejor que yo. Ten cuidado con en sintaxis del parámetro STYLE, es muy sensitiva si falta un ; o un espacio.
En general te consejo aprender CSS si quieres tomar control total de tu diseño de páginas web.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas