Formato de $ en Cuadro de texto en Formulario Access

Tengo el siguiente problema dentro de un informe en Access, tengo varios cuadros de texto en donde para dar formato de símbolo $ a los valores aplico en la propiedad formato de dichos cuadros de texto:
$#.##0,0[Negro];($#.##0,0)[Rojo];"Cero";"Null"
y al momento de ejecutar el informe me sale bien con el simbolo $ al lado del valor como deseo,,,pero desafortunadamente en uno de los cuadros de texto que estan dentro del informe al dar en formato: $#.##0,0[Negro];($#.##0,0)[Rojo];"Cero";"Null"
Me salen los valores pero sin el símbolo $ al lado como si se hace en los otros cuadros de texto, ¿qué estará sucediendo?.
Gracias... Por tu ayuda .
1

1 respuesta

Respuesta
1
Porque no copias uno de los cuadros de texto que si funcionan y lo pegas en lugar del que no te funciona solo cambia el nombre, en ocasiones estos trean algo raro, pruébalo.
Hola muchas gracias por tu respuesta... el inconveniente pues desafortunadamente sigue ya hecho de todo incluso aplique la propiedad copiar formato (La brochita) y no me permitió cambiar el formato me lo deja solo como numero más no con la simbología que si me sale en los otros cuadros de texto,, e incluso inserte otro cuadro de texto y le puse el mismo origen de datos y me sale sin la simbología de $ Y sin el separador de miles.
Gracias!.
mi mail es wayunet1@hotmail.com
¿Ya revisaste la tabla? Que el tipo de campo sea exactamente igual que los demás campos
Hola muchas gracias, por su interés en mi inconveniente, hice lo que me habías dicho que hiciera respecto al campo que tengo en el problema... pues dicho cuadro de texto dentro del informe proviene de un campo que esta definido de tipo Texto dentro de una tabla, el cuadro de texto al darle formato $#. ##0,0[Negro];($#. ##0,0)[Rojo];"Cero";"Null"
no me hace nada... ¿sera qué es necesario cambiarlo a tipo de dato a tipo de dato numérico?
Gracias.
Has la prueba, solo trabaja sobre una copia
Hola muchas gracias or la atención y discúlpeme la tardanza,,, opte por anteponer el símbolo $ al campo dentro del informe... estuve tratando de todas las maneras posibles y no fue posible aplicar ese formato e incluso copiando un campo dentro del reporte y aplicándole las mismas propiedades,,, de verdad muchas gracias por su atención..
Pero necesito que me ayudaras con algo para un proyecto: te doy mi correo electrónico:
wayunet1@hotmail.com
Y si deseas me puedes dar el tuyo para poder expplicarle que es lo que necesitamos en el proyecto...
Gracias..
Att. Hernán Camilo Martínez Valenzuela.
No tengo inconveniente en ayudarte pero solo que estoy saturado de trabajo más la ayuda que doy en los foros, tu dirás si te urge me voy a tardar algo de tiempo.
Hola pues no es que sea mucho lo que te tengo que explicar, pero el problema es que para mi jefe es muy importante solucionar lo siguiente:
Resulta que cree un formulario con asistentes en dicho formulario se incluyen dos subformularios pero dentro de uno de esos subformularios tengo un cuadro combinado y dos cuadros de lista resulta que cuando dichos subformularios se crean o se vinculan automáticamente al crear un formulario mediante asistente subformularios se ven de forma tabular pero eso no es problema el problema es que los cuadros de lista se "convierten " en cuadros combinados y el problema es que la información del cuadro de lista no se muestra directamente sobre el subformulario sino que hay que seleccionarla de una lista desplegable.
Para explicarte más sencillamente el problema que tengo es como si dentro de un subformulario al seleccionar una lista de países (que esta dentro de un cuadro combinado)tuviera que seleccionar dentro de un cuadro de lista varias capitales, la idea es que aparezca automáticamente una sola ciudad en el cuadro de lista.. claro que te tengo que decir que los campos dentro del subformulario que aparecen denotados como cuadros de lista pero que se comportan como cuadros combinados al ejecutar el formulario provienen en la tabla de origen con la propiedad "Columna de búsqueda" como tu sabes es una tabla cuyos datos provienen de otra tabla.
Muchas gracias por su atención... además si estas muy ocupado me gustaría que me dijeras a donde puedo o con quien pudiera ayudar con este problema.
Gracias!
Att .Hernán Camilo.
Hernán la verdad que estoy saturado de trabajo aunado a que tengo como 15 preguntas en espera de contestar lo cual hago en "mis pocos ratos libres", pues te sugiero que entres a www.lawebdelprogramador.com y entra al foro de access, ahí hay muchos programadores muy chipotles y verás que sobra quién te ayude.

Añade tu respuesta

Haz clic para o

Más respuestas relacionadas